aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-fail2ban/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-fail2ban/Makefile')
-rw-r--r--security/py-fail2ban/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
new file mode 100644
index 000000000000..a662d80884eb
--- /dev/null
+++ b/security/py-fail2ban/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: fail2ban
+# Date created: 13 January 2009
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fail2ban
+PORTVERSION= 0.8.3
+CATEGORIES= security python
+MASTER_SITES= SF
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= scans log files and bans IP that makes too many password failures.
+
+USE_BZIP2= yes
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PYDISTUTILS_INSTALLARGS+= --install-purelib=${PYTHON_SITELIBDIR} \
+ --install-data=${ETCDIR}
+
+FILES= ${WRKSRC}/fail2ban-regex \
+ ${WRKSRC}/man/fail2ban-client.1 \
+ ${WRKSRC}/man/fail2ban-client.h2m \
+ ${WRKSRC}/setup.py \
+ ${WRKSRC}/client/configreader.py \
+ ${WRKSRC}/fail2ban-client
+
+post-patch:
+ @${ECHO_CMD} ${FILES} | ${XARGS} ${REINPLACE_CMD} -e 's,/etc/fail2ban,${ETCDIR},g'
+
+.include <bsd.port.mk>