aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-fteproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-fteproxy/Makefile')
-rw-r--r--security/py-fteproxy/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/py-fteproxy/Makefile b/security/py-fteproxy/Makefile
new file mode 100644
index 000000000000..a76af8e9bf6e
--- /dev/null
+++ b/security/py-fteproxy/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= fteproxy
+DISTVERSION= 0.2.19
+CATEGORIES= security net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= egypcio@googlemail.com
+COMMENT= Programmable proxy for censorship circumvention
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=17.9.0:devel/py-twisted@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libfte>=0.1.0:net/py-libfte@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}obfsproxy-tor>=0.2.13:security/py-obfsproxy-tor@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyptlib>=0.0.6:security/py-pyptlib@${PY_FLAVOR}
+
+USES= python:2.7
+USE_PYTHON= autoplist distutils
+
+NO_BUILD= yes
+
+.include <bsd.port.mk>