aboutsummaryrefslogtreecommitdiffstats
path: root/security/quintuple-agent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/quintuple-agent/Makefile')
-rw-r--r--security/quintuple-agent/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/security/quintuple-agent/Makefile b/security/quintuple-agent/Makefile
index 4b5610e010d9..e1fc44c9ca4f 100644
--- a/security/quintuple-agent/Makefile
+++ b/security/quintuple-agent/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= quintuple-agent
-PORTVERSION= 1.0.3
-PORTREVISION= 2
+PORTVERSION= 1.0.4
CATEGORIES= security
-MASTER_SITES= http://www.vibe.at/tools/q-agent/
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= vs@FreeBSD.org
COMMENT= Quintuple Agent is a program that stores secrets for you
USE_GETTEXT= yes
+USE_GETOPT_LONG=yes
USE_GNOME= glib12
.ifndef(WITHOUT_X11)
USE_GNOME+= gtk12
@@ -23,6 +24,7 @@ PLIST_SUB+= X11=""
PLIST_SUB+= X11="@comment "
.endif
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
#catgets disabled because it can't find all messages:
@@ -30,6 +32,8 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
.ifdef(WITHOUT_X11)
CONFIGURE_ARGS+=--disable-gtktest
.endif
+USE_GMAKE= yes
+MAKE_ARGS= SUBDIRS="doc intl lib m4 po . test"
MAN1= agpg.1 apgp.1 q-agent.1 secret-ask.1 q-client.1 secret-query.1