aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ssh/Makefile')
-rw-r--r--security/ssh/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index f06d971948e9..d00ccc3401ba 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -1,16 +1,16 @@
# New ports collection makefile for: ssh
-# Version required: 1.2.19
+# Version required: 1.2.20
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.38 1997/04/16 19:48:09 ache Exp $
+# $Id: Makefile,v 1.39 1997/04/20 13:53:01 wosch Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
#
-DISTNAME= ssh-1.2.19
-CATEGORIES= security net perl5
+DISTNAME= ssh-1.2.20
+CATEGORIES= security net
MASTER_SITES= ftp://ftp.funet.fi/pub/unix/security/login/ssh/
MAINTAINER= torstenb@FreeBSD.ORG
@@ -35,6 +35,15 @@ GNU_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-etcdir=${PREFIX}/etc
+#Uncomment if all your users are in their own group and their homedir
+#is writeable by that group. Beware the security implications!
+#CONFIGURE_ARGS+= --enable-group-writeability
+
+#Uncomment if you want to allow ssh to emulate an unencrypted rsh connection
+#over a secure medium. This is normally dangerous since it can lead to the
+#disclosure keys and passwords.
+#CONFIGURE_ARGS+= --with-none
+
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
CONFIGURE_ARGS+= --with-rsaref
.endif