aboutsummaryrefslogtreecommitdiffstats
path: root/security/wipe
diff options
context:
space:
mode:
Diffstat (limited to 'security/wipe')
-rw-r--r--security/wipe/Makefile38
-rw-r--r--security/wipe/distinfo2
-rw-r--r--security/wipe/files/500040-patch-blkdev.c22
-rw-r--r--security/wipe/files/patch-Makefile.in16
-rw-r--r--security/wipe/pkg-descr5
-rw-r--r--security/wipe/pkg-plist1
6 files changed, 84 insertions, 0 deletions
diff --git a/security/wipe/Makefile b/security/wipe/Makefile
new file mode 100644
index 000000000000..a19f3c7ff67f
--- /dev/null
+++ b/security/wipe/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: wipe
+# Date created: 04 February 2005
+# Whom: Edson Brandi <ebrandi@fugspbr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wipe
+PORTVERSION= 2.2.0
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ebrandi@fugspbr.org
+COMMENT= File and block device wiping utility
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+MAN1= wipe.1
+PORTDOCS= CHANGES INSTALL LICENSE README TESTING TODO copyright
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500039
+EXTRA_PATCHES= ${PATCHDIR}/500040-patch-blkdev.c
+.endif
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/wipe.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/wipe
+ for i in ${PORTDOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$i ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/wipe/distinfo b/security/wipe/distinfo
new file mode 100644
index 000000000000..0bb1ffec975f
--- /dev/null
+++ b/security/wipe/distinfo
@@ -0,0 +1,2 @@
+MD5 (wipe-2.2.0.tar.bz2) = 1e1366c6407e7910f6131ebfee9f1ea6
+SIZE (wipe-2.2.0.tar.bz2) = 70134
diff --git a/security/wipe/files/500040-patch-blkdev.c b/security/wipe/files/500040-patch-blkdev.c
new file mode 100644
index 000000000000..cfb7ff3eea1b
--- /dev/null
+++ b/security/wipe/files/500040-patch-blkdev.c
@@ -0,0 +1,22 @@
+--- blkdev.c.orig Sun Aug 3 16:07:29 2003
++++ blkdev.c Sat Mar 5 00:23:40 2005
+@@ -128,6 +128,10 @@
+ int code;
+
+ #ifdef BSD_BLKDEV
++ struct partinfo {
++ struct disklabel *disklab;
++ struct partition *part;
++ };
+ struct partinfo pinfo;
+ #endif
+
+@@ -160,7 +164,7 @@
+ }
+
+ #ifdef BSD_BLKDEV
+- if (ioctl(f->fd, DIOCGPART, &pinfo))
++ if (ioctl(f->fd, DIOCGDINFO, &pinfo))
+ {
+ fprintf(stderr, "\r%s: ioctl failed, can't get disklabel for `%s': %s\n",
+ argvzero, f->name, strerror(errno));
diff --git a/security/wipe/files/patch-Makefile.in b/security/wipe/files/patch-Makefile.in
new file mode 100644
index 000000000000..d3d802db0f47
--- /dev/null
+++ b/security/wipe/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig Sat Aug 30 18:18:03 2003
++++ Makefile.in Sat Mar 5 00:24:22 2005
+@@ -60,13 +60,6 @@
+ $(INSTALL_BIN) -d $(bindir)
+ $(INSTALL_BIN) -s $(BIN_OUT) $(bindir)
+ $(INSTALL) -d $(mandir)/man1
+- $(INSTALL) -o root -m 0644 wipe.1 $(mandir)/man1/
+- rm -rf $(datadir)/doc/wipe*
+- $(INSTALL) -d $(datadir)/doc/wipe
+-
+- for file in $(DOCS); do \
+- $(INSTALL) -o root -m 0644 $$file $(datadir)/doc/wipe/; \
+- done
+
+ install_home: $(BIN_OUT)
+ strip $(BIN_OUT)
diff --git a/security/wipe/pkg-descr b/security/wipe/pkg-descr
new file mode 100644
index 000000000000..dd1a05d6636d
--- /dev/null
+++ b/security/wipe/pkg-descr
@@ -0,0 +1,5 @@
+Wipe is a file and block device wiping utility
+
+WWW: http://wipe.sourceforge.net/
+
+Author: Tom Vier <nester@users.sf.net>
diff --git a/security/wipe/pkg-plist b/security/wipe/pkg-plist
new file mode 100644
index 000000000000..c0d90a8b6181
--- /dev/null
+++ b/security/wipe/pkg-plist
@@ -0,0 +1 @@
+bin/wipe