aboutsummaryrefslogtreecommitdiffstats
path: root/security/xinetd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/xinetd/Makefile')
-rw-r--r--security/xinetd/Makefile30
1 files changed, 18 insertions, 12 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index e9b243c06c94..3f765833bcb7 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -5,29 +5,35 @@ PORTNAME= xinetd
PORTVERSION= 2.3.15
PORTREVISION= 1
CATEGORIES= security ipv6
-MASTER_SITES= http://www.xinetd.org/
+MASTER_SITES= GENTOO/distfiles
MAINTAINER= sem@FreeBSD.org
COMMENT= Replacement for inetd with better control and logging
-LICENSE= BSD
-
-USES= gmake
GNU_CONFIGURE= yes
USE_RC_SUBR= xinetd
ALL_TARGET= build
-CONFIGURE_ARGS+= --with-loadavg --with-libwrap --with-ipv6
+CONFIGURE_ARGS+= --with-loadavg
+
+USES= shebangfix perl5
+USE_PERL5= run
+SHEBANG_FILES= ${WRKSRC}/xinetd/xconv.pl
+
+OPTIONS_DEFINE= IPV6 LIBWRAP
+OPTIONS_DEFAULT= LIBWRAP
-MAN5= xinetd.conf.5
-MAN8= xconv.8 xinetd.8 xinetd.log.8
+IPV6_CONFIGURE_WITH= ipv6
+LIBWRAP_CONFIGURE_WITH= libwrap
-NO_STAGE= yes
post-patch:
- ${FIND} ${WRKSRC}/libs/src -name Makefile.in | ${XARGS} \
- ${REINPLACE_CMD} -e 's!\@INSTALL\@!/bin/cp!; s!-m 640!!'
@${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/xinetd/xconfig.h
-post-install:
- @${STRIP_CMD} ${PREFIX}/sbin/xinetd
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xinetd/xinetd ${STAGEDIR}${PREFIX}/sbin/xinetd
+ ${INSTALL_SCRIPT} ${WRKSRC}/xinetd/xconv.pl ${STAGEDIR}${PREFIX}/bin/xconv
+ ${INSTALL_MAN} ${WRKSRC}/xinetd/xinetd.conf.man ${STAGEDIR}${PREFIX}/man/man5/xinetd.conf.5
+ ${INSTALL_MAN} ${WRKSRC}/xinetd/xconv.pl.8 ${STAGEDIR}${PREFIX}/man/man8/xconv.8
+ ${INSTALL_MAN} ${WRKSRC}/xinetd/xinetd.man ${STAGEDIR}${PREFIX}/man/man8/xinetd.8
+ ${INSTALL_MAN} ${WRKSRC}/xinetd/xinetd.log.man ${STAGEDIR}${PREFIX}/man/man8/xinetd.log.8
.include <bsd.port.mk>