aboutsummaryrefslogtreecommitdiffstats
path: root/security/zxid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/zxid/Makefile')
-rw-r--r--security/zxid/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
new file mode 100644
index 000000000000..5aa68f862e00
--- /dev/null
+++ b/security/zxid/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: zxid
+# Date created: 2007-07-06
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zxid
+PORTVERSION= 0.17
+CATEGORIES= security www
+MASTER_SITES= http://zxid.org/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Open Source IdM for the Masses - SAML SSO
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+MAKE_ARGS+= CC="${CC}" CURL_ROOT="${LOCALBASE}" LD="${CC}" \
+ PREFIX="${PREFIX}" OPENSSL_ROOT="${OPENSSLBASE}"
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+
+.include <bsd.port.mk>