aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/tpm2-abrmd/Makefile3
-rw-r--r--security/tpm2-abrmd/distinfo6
-rw-r--r--security/tpm2-abrmd/files/patch-src_tabrmd-defaults.h11
-rw-r--r--security/tpm2-abrmd/files/patch-src_tpm2-header.c18
-rw-r--r--security/tpm2-abrmd/files/patch-src_util.h20
5 files changed, 4 insertions, 54 deletions
diff --git a/security/tpm2-abrmd/Makefile b/security/tpm2-abrmd/Makefile
index 4f47422c73aa..8febe32170bd 100644
--- a/security/tpm2-abrmd/Makefile
+++ b/security/tpm2-abrmd/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= tpm2-abrmd
-DISTVERSION= 2.2.0
-PORTREVISION= 1
+DISTVERSION= 2.3.2
CATEGORIES= security
MASTER_SITES= https://github.com/tpm2-software/tpm2-abrmd/releases/download/${DISTVERSION}/
diff --git a/security/tpm2-abrmd/distinfo b/security/tpm2-abrmd/distinfo
index f4d35c6db3c2..8495e6a1052b 100644
--- a/security/tpm2-abrmd/distinfo
+++ b/security/tpm2-abrmd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1566436559
-SHA256 (tpm2-abrmd-2.2.0.tar.gz) = 2a75a09802290d88f7806d1294b0070f92dd3f138a211834caa4cc04bd876ed1
-SIZE (tpm2-abrmd-2.2.0.tar.gz) = 569459
+TIMESTAMP = 1589830931
+SHA256 (tpm2-abrmd-2.3.2.tar.gz) = c9375be6e9cab9ec01c343821bd97ea8a3390e255c08ac931656addd132ea89f
+SIZE (tpm2-abrmd-2.3.2.tar.gz) = 576381
diff --git a/security/tpm2-abrmd/files/patch-src_tabrmd-defaults.h b/security/tpm2-abrmd/files/patch-src_tabrmd-defaults.h
deleted file mode 100644
index 4dcc00f63ed1..000000000000
--- a/security/tpm2-abrmd/files/patch-src_tabrmd-defaults.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tabrmd-defaults.h.orig 2019-09-23 18:08:25 UTC
-+++ src/tabrmd-defaults.h
-@@ -17,7 +17,7 @@
- #define TABRMD_SESSIONS_MAX_DEFAULT 4
- #define TABRMD_SESSIONS_MAX 64
- #define TABRMD_TCTI_FILENAME_DEFAULT "libtss2-tcti-device.so.0"
--#define TABRMD_TCTI_CONF_DEFAULT NULL
-+#define TABRMD_TCTI_CONF_DEFAULT "device:/dev/tpm"
- #define TABRMD_TRANSIENT_MAX_DEFAULT 27
- #define TABRMD_TRANSIENT_MAX 100
-
diff --git a/security/tpm2-abrmd/files/patch-src_tpm2-header.c b/security/tpm2-abrmd/files/patch-src_tpm2-header.c
deleted file mode 100644
index a5adadcd326b..000000000000
--- a/security/tpm2-abrmd/files/patch-src_tpm2-header.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/tpm2-header.c.orig 2019-08-22 04:36:24 UTC
-+++ src/tpm2-header.c
-@@ -4,7 +4,6 @@
- * All rights reserved.
- */
- #include <assert.h>
--#include <endian.h>
- #include <glib.h>
- #include <inttypes.h>
- #include <stddef.h>
-@@ -13,6 +12,7 @@
- #include <tss2/tss2_tpm2_types.h>
-
- #include "tpm2-header.h"
-+#include "util.h"
-
- /**
- * Extract the 'tag' field from the tpm command header. This is a
diff --git a/security/tpm2-abrmd/files/patch-src_util.h b/security/tpm2-abrmd/files/patch-src_util.h
deleted file mode 100644
index 78e912d22039..000000000000
--- a/security/tpm2-abrmd/files/patch-src_util.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/util.h.orig 2019-08-22 19:25:53 UTC
-+++ src/util.h
-@@ -9,8 +9,17 @@
- #include <glib.h>
- #include <gio/gio.h>
- #include <tss2/tss2_tpm2_types.h>
-+#if defined(__FreeBSD__)
-+#include <sys/endian.h>
-+#endif
-
- #include "control-message.h"
-+
-+#if defined(__FreeBSD__)
-+#ifndef POLLRDHUP
-+#define POLLRDHUP 0
-+#endif
-+#endif
-
- /* Use to suppress "unused parameter" warnings: */
- #define UNUSED_PARAM(p) ((void)(p))