aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/clusterssh/Makefile14
-rw-r--r--security/clusterssh/distinfo6
-rw-r--r--security/clusterssh/pkg-plist4
3 files changed, 18 insertions, 6 deletions
diff --git a/security/clusterssh/Makefile b/security/clusterssh/Makefile
index a200afc9c9bc..ac5c2b60a730 100644
--- a/security/clusterssh/Makefile
+++ b/security/clusterssh/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= clusterssh
-DISTVERSIONPREFIX= release-
-DISTVERSION= 4.13.2
+DISTVERSIONPREFIX= v
+DISTVERSION= 4.13.2_01
CATEGORIES= security net
MAINTAINER= ehaupt@FreeBSD.org
@@ -40,6 +40,7 @@ TEST_DEPENDS= p5-CPAN-Changes>=0:devel/p5-CPAN-Changes \
USES= perl5
USE_GITHUB= yes
USE_PERL5= modbuild
+
NO_ARCH= yes
GH_ACCOUNT= duncs
@@ -47,6 +48,13 @@ GH_ACCOUNT= duncs
OPTIONS_SUB= yes
OPTIONS_DEFINE= BASH
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502701
+BUILD_DEPENDS+= p5-Getopt-Long>=2.50:devel/p5-Getopt-Long
+RUN_DEPENDS+= p5-Getopt-Long>=2.50:devel/p5-Getopt-Long
+.endif
+
post-install-BASH-off:
@${RM} ${STAGEDIR}${PREFIX}/bin/clusterssh_bash_completion.dist
@@ -55,4 +63,4 @@ post-install-BASH-on:
${MV} ${STAGEDIR}${PREFIX}/bin/clusterssh_bash_completion.dist \
${STAGEDIR}${PREFIX}/etc/bash_completion.d/clusterssh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/clusterssh/distinfo b/security/clusterssh/distinfo
index 688b59380d8f..bf66f6a824ae 100644
--- a/security/clusterssh/distinfo
+++ b/security/clusterssh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1521068034
-SHA256 (duncs-clusterssh-release-4.13.2_GH0.tar.gz) = 02fec755beafe07a9b08aa0ed72149742e8d9ff0d2c75e424b9d97ddd20edb84
-SIZE (duncs-clusterssh-release-4.13.2_GH0.tar.gz) = 84792
+TIMESTAMP = 1543146093
+SHA256 (duncs-clusterssh-v4.13.2_01_GH0.tar.gz) = be6da42d448d925485d24c060f93215980e4e603476d61e18e79e219facea65a
+SIZE (duncs-clusterssh-v4.13.2_01_GH0.tar.gz) = 73422
diff --git a/security/clusterssh/pkg-plist b/security/clusterssh/pkg-plist
index e33eb349a5e8..49951e987d6c 100644
--- a/security/clusterssh/pkg-plist
+++ b/security/clusterssh/pkg-plist
@@ -19,6 +19,8 @@ bin/ctel
%%PERL5_MAN3%%/App::ClusterSSH::L10N.3.gz
%%PERL5_MAN3%%/App::ClusterSSH::L10N::en.3.gz
%%PERL5_MAN3%%/App::ClusterSSH::Range.3.gz
+%%PERL5_MAN3%%/App::ClusterSSH::Window.3.gz
+%%PERL5_MAN3%%/App::ClusterSSH::Window::Tk.3.gz
%%SITE_PERL%%/App/ClusterSSH.pm
%%SITE_PERL%%/App/ClusterSSH/Base.pm
%%SITE_PERL%%/App/ClusterSSH/Cluster.pm
@@ -29,3 +31,5 @@ bin/ctel
%%SITE_PERL%%/App/ClusterSSH/L10N.pm
%%SITE_PERL%%/App/ClusterSSH/L10N/en.pm
%%SITE_PERL%%/App/ClusterSSH/Range.pm
+%%SITE_PERL%%/App/ClusterSSH/Window.pm
+%%SITE_PERL%%/App/ClusterSSH/Window/Tk.pm