aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/hs-Crypto/Makefile3
-rw-r--r--security/hs-DRBG/Makefile3
-rw-r--r--security/hs-HsOpenSSL/Makefile3
-rw-r--r--security/hs-RSA/Makefile3
-rw-r--r--security/hs-SHA/Makefile3
-rw-r--r--security/hs-cipher-aes/Makefile3
-rw-r--r--security/hs-cipher-aes128/Makefile3
-rw-r--r--security/hs-cipher-blowfish/Makefile3
-rw-r--r--security/hs-cipher-camellia/Makefile3
-rw-r--r--security/hs-cipher-des/Makefile3
-rw-r--r--security/hs-cipher-rc4/Makefile3
-rw-r--r--security/hs-clientsession/Makefile3
-rw-r--r--security/hs-cprng-aes/Makefile3
-rw-r--r--security/hs-crypto-api/Makefile3
-rw-r--r--security/hs-crypto-cipher-types/Makefile3
-rw-r--r--security/hs-crypto-conduit/Makefile3
-rw-r--r--security/hs-crypto-numbers/Makefile3
-rw-r--r--security/hs-crypto-pubkey-types/Makefile3
-rw-r--r--security/hs-crypto-pubkey/Makefile3
-rw-r--r--security/hs-crypto-random-api/Makefile3
-rw-r--r--security/hs-crypto-random/Makefile3
-rw-r--r--security/hs-cryptocipher/Makefile3
-rw-r--r--security/hs-cryptohash-conduit/Makefile3
-rw-r--r--security/hs-cryptohash-cryptoapi/Makefile3
-rw-r--r--security/hs-cryptohash-md5/Makefile3
-rw-r--r--security/hs-cryptohash-sha1/Makefile3
-rw-r--r--security/hs-cryptohash-sha256/Makefile3
-rw-r--r--security/hs-cryptohash/Makefile3
-rw-r--r--security/hs-cryptonite-conduit/Makefile3
-rw-r--r--security/hs-cryptonite/Makefile3
-rw-r--r--security/hs-digest/Makefile3
-rw-r--r--security/hs-ed25519/Makefile3
-rw-r--r--security/hs-entropy/Makefile3
-rw-r--r--security/hs-gnutls/Makefile3
-rw-r--r--security/hs-hackage-security/Makefile3
-rw-r--r--security/hs-monadcryptorandom/Makefile3
-rw-r--r--security/hs-nonce/Makefile3
-rw-r--r--security/hs-pem/Makefile3
-rw-r--r--security/hs-pureMD5/Makefile3
-rw-r--r--security/hs-pwstore-fast/Makefile3
-rw-r--r--security/hs-skein/Makefile3
-rw-r--r--security/hs-tls-session-manager/Makefile3
-rw-r--r--security/hs-tls/Makefile3
-rw-r--r--security/hs-x509-store/Makefile3
-rw-r--r--security/hs-x509-system/Makefile3
-rw-r--r--security/hs-x509-validation/Makefile3
-rw-r--r--security/hs-x509/Makefile3
47 files changed, 141 insertions, 0 deletions
diff --git a/security/hs-Crypto/Makefile b/security/hs-Crypto/Makefile
index b061508ebce9..a9dc3b1c6b68 100644
--- a/security/hs-Crypto/Makefile
+++ b/security/hs-Crypto/Makefile
@@ -8,6 +8,9 @@ CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Collects together existing Haskell cryptographic functions
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= HUnit QuickCheck>=2.4.0.1 random
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-DRBG/Makefile b/security/hs-DRBG/Makefile
index a2a68e310f7e..653dab63109a 100644
--- a/security/hs-DRBG/Makefile
+++ b/security/hs-DRBG/Makefile
@@ -10,6 +10,9 @@ COMMENT= Deterministic random bit generator based HMACs, Hashes, and Ciphers
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= cereal>=0.2 cipher-aes128>=0.6 crypto-api>=0.13 \
cryptohash-cryptoapi>=0.1 entropy mtl>=2.0 parallel \
prettyclass tagged>=0.2
diff --git a/security/hs-HsOpenSSL/Makefile b/security/hs-HsOpenSSL/Makefile
index 895829b619f3..871f3e763170 100644
--- a/security/hs-HsOpenSSL/Makefile
+++ b/security/hs-HsOpenSSL/Makefile
@@ -8,6 +8,9 @@ CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Partial OpenSSL binding for Haskell
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= network>=2.1 old-locale>=1.0
USES= ssl
diff --git a/security/hs-RSA/Makefile b/security/hs-RSA/Makefile
index 641686309b7b..567058736110 100644
--- a/security/hs-RSA/Makefile
+++ b/security/hs-RSA/Makefile
@@ -10,6 +10,9 @@ COMMENT= Implementation of RSA, using the padding schemes of PKCS#1 v2.1
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= crypto-api>=0.10 crypto-pubkey-types>=0.2 pureMD5>=2.1 \
SHA>0
diff --git a/security/hs-SHA/Makefile b/security/hs-SHA/Makefile
index 502ba8877c5b..fe4a264768ec 100644
--- a/security/hs-SHA/Makefile
+++ b/security/hs-SHA/Makefile
@@ -10,6 +10,9 @@ COMMENT= Implementations of the SHA suite of message digest functions
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
FLAGS_DEFINE= EXE
EXE_DESC= Build executables similar to 'md5sum'
diff --git a/security/hs-cipher-aes/Makefile b/security/hs-cipher-aes/Makefile
index ef9c857f33e1..6c795ef1f411 100644
--- a/security/hs-cipher-aes/Makefile
+++ b/security/hs-cipher-aes/Makefile
@@ -10,6 +10,9 @@ COMMENT= Fast AES cipher implementation with advanced mode of operations
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable crypto-cipher-types>=0.0.6 securemem>=0.1.2
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-cipher-aes128/Makefile b/security/hs-cipher-aes128/Makefile
index 9b0676e14e89..6f29871619d4 100644
--- a/security/hs-cipher-aes128/Makefile
+++ b/security/hs-cipher-aes128/Makefile
@@ -10,6 +10,9 @@ COMMENT= AES and common modes using AES-NI when available
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= cereal crypto-api>=0.13 tagged
FLAGS_DISABLE= test halvm
diff --git a/security/hs-cipher-blowfish/Makefile b/security/hs-cipher-blowfish/Makefile
index 8cf143e319f5..1f97f7543e24 100644
--- a/security/hs-cipher-blowfish/Makefile
+++ b/security/hs-cipher-blowfish/Makefile
@@ -10,6 +10,9 @@ COMMENT= Blowfish cipher
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable crypto-cipher-types>=0.0.3 securemem>=0.1.2 \
vector
diff --git a/security/hs-cipher-camellia/Makefile b/security/hs-cipher-camellia/Makefile
index 9a91395d7eb2..6ca87ae774a0 100644
--- a/security/hs-cipher-camellia/Makefile
+++ b/security/hs-cipher-camellia/Makefile
@@ -10,6 +10,9 @@ COMMENT= Camellia block cipher primitives
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable crypto-cipher-types>=0.0.3 securemem>=0.1.2 \
vector
diff --git a/security/hs-cipher-des/Makefile b/security/hs-cipher-des/Makefile
index bb1fbab54406..7bdd4443d7e7 100644
--- a/security/hs-cipher-des/Makefile
+++ b/security/hs-cipher-des/Makefile
@@ -10,6 +10,9 @@ COMMENT= DES and 3DES primitives
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable crypto-cipher-types>=0.0.3 securemem>=0.1.2
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-cipher-rc4/Makefile b/security/hs-cipher-rc4/Makefile
index 1fc0748de910..c732dd1cf47d 100644
--- a/security/hs-cipher-rc4/Makefile
+++ b/security/hs-cipher-rc4/Makefile
@@ -10,6 +10,9 @@ COMMENT= Fast RC4 cipher implementation
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable crypto-cipher-types>=0.0.5
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-clientsession/Makefile b/security/hs-clientsession/Makefile
index b95845815bd5..c552665749b6 100644
--- a/security/hs-clientsession/Makefile
+++ b/security/hs-clientsession/Makefile
@@ -10,6 +10,9 @@ COMMENT= Securely store session data in a client-side cookie
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= base64-bytestring>=0.1.1.1 cereal>=0.3 cipher-aes>=0.1.7 \
cprng-aes>=0.2 crypto-api>=0.8 crypto-random entropy>=0.2.1 \
setenv skein>=1.0.0 tagged>=0.1
diff --git a/security/hs-cprng-aes/Makefile b/security/hs-cprng-aes/Makefile
index 1a9e887e90e3..8dc14be114f0 100644
--- a/security/hs-cprng-aes/Makefile
+++ b/security/hs-cprng-aes/Makefile
@@ -10,6 +10,9 @@ COMMENT= Crypto Pseudo Random Number Generator using AES in counter mode
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable cipher-aes>=0.2.9 crypto-random>=0.0.7
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-crypto-api/Makefile b/security/hs-crypto-api/Makefile
index d5d5558a846c..19dd3625a170 100644
--- a/security/hs-crypto-api/Makefile
+++ b/security/hs-crypto-api/Makefile
@@ -10,6 +10,9 @@ COMMENT= Generic interface for cryptographic operations
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= cereal>=0.2 entropy tagged>=0.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-crypto-cipher-types/Makefile b/security/hs-crypto-cipher-types/Makefile
index 6ba0c4e9c74b..5c3197b97bf1 100644
--- a/security/hs-crypto-cipher-types/Makefile
+++ b/security/hs-crypto-cipher-types/Makefile
@@ -10,6 +10,9 @@ COMMENT= Generic cryptography cipher types
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable>=0.1.1 securemem>=0.1.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-crypto-conduit/Makefile b/security/hs-crypto-conduit/Makefile
index cc3908e37f21..cd6ed7e2e432 100644
--- a/security/hs-crypto-conduit/Makefile
+++ b/security/hs-crypto-conduit/Makefile
@@ -10,6 +10,9 @@ COMMENT= Conduit interface for cryptographic operations (from crypto-api)
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= cereal conduit conduit-extra crypto-api resourcet
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-crypto-numbers/Makefile b/security/hs-crypto-numbers/Makefile
index 8c470b1bb856..22a47aeff244 100644
--- a/security/hs-crypto-numbers/Makefile
+++ b/security/hs-crypto-numbers/Makefile
@@ -10,6 +10,9 @@ COMMENT= Cryptographic numbers: functions and algorithms
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= crypto-random>=0.0.0 vector
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-crypto-pubkey-types/Makefile b/security/hs-crypto-pubkey-types/Makefile
index 3a0cda647122..d88e9c615064 100644
--- a/security/hs-crypto-pubkey-types/Makefile
+++ b/security/hs-crypto-pubkey-types/Makefile
@@ -10,6 +10,9 @@ COMMENT= Generic cryptography Public keys algorithm types
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= asn1-encoding asn1-types>=0.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-crypto-pubkey/Makefile b/security/hs-crypto-pubkey/Makefile
index 7d53f804b843..e5f70ec84efa 100644
--- a/security/hs-crypto-pubkey/Makefile
+++ b/security/hs-crypto-pubkey/Makefile
@@ -10,6 +10,9 @@ COMMENT= Public Key cryptography
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable crypto-numbers>=0.2.2 crypto-pubkey-types>=0.4.1 \
crypto-random>=0.0.0 cryptohash>=0.9.1
diff --git a/security/hs-crypto-random-api/Makefile b/security/hs-crypto-random-api/Makefile
index d722b7e65f4b..51e7595d30be 100644
--- a/security/hs-crypto-random-api/Makefile
+++ b/security/hs-crypto-random-api/Makefile
@@ -10,6 +10,9 @@ COMMENT= Simple random generators API for cryptography related code
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= entropy
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-crypto-random/Makefile b/security/hs-crypto-random/Makefile
index f0e23b1aa46f..b25f72adc2c1 100644
--- a/security/hs-crypto-random/Makefile
+++ b/security/hs-crypto-random/Makefile
@@ -10,6 +10,9 @@ COMMENT= Simple cryptographic random related types
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= securemem vector
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-cryptocipher/Makefile b/security/hs-cryptocipher/Makefile
index 0ce337628c52..e8d6b0216ca3 100644
--- a/security/hs-cryptocipher/Makefile
+++ b/security/hs-cryptocipher/Makefile
@@ -10,6 +10,9 @@ COMMENT= Symmetrical block and stream ciphers
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= cipher-aes>=0.2.3 cipher-blowfish>=0.0 cipher-camellia>=0.0 \
cipher-des>=0.0 cipher-rc4>=0.1.3 crypto-cipher-types>=0.0.8
diff --git a/security/hs-cryptohash-conduit/Makefile b/security/hs-cryptohash-conduit/Makefile
index b64bfc6e03b1..61a74ab83f7d 100644
--- a/security/hs-cryptohash-conduit/Makefile
+++ b/security/hs-cryptohash-conduit/Makefile
@@ -10,6 +10,9 @@ COMMENT= Cryptohash conduit
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= conduit conduit-extra cryptohash resourcet
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-cryptohash-cryptoapi/Makefile b/security/hs-cryptohash-cryptoapi/Makefile
index b2eb294cf8e1..60292b1b80a7 100644
--- a/security/hs-cryptohash-cryptoapi/Makefile
+++ b/security/hs-cryptohash-cryptoapi/Makefile
@@ -10,6 +10,9 @@ COMMENT= Crypto-api interfaces for cryptohash
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= cereal>=0.2 crypto-api>=0.11 cryptohash>=0.8.0 tagged>=0.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-cryptohash-md5/Makefile b/security/hs-cryptohash-md5/Makefile
index 2478f464ec51..da192a482021 100644
--- a/security/hs-cryptohash-md5/Makefile
+++ b/security/hs-cryptohash-md5/Makefile
@@ -10,5 +10,8 @@ COMMENT= A practical incremental and one-pass, pure API to the MD5 hash algorith
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-cryptohash-sha1/Makefile b/security/hs-cryptohash-sha1/Makefile
index e5c3fe5b347e..a5527a616758 100644
--- a/security/hs-cryptohash-sha1/Makefile
+++ b/security/hs-cryptohash-sha1/Makefile
@@ -10,5 +10,8 @@ COMMENT= A practical incremental and one-pass, pure API to the SHA-1 hash
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-cryptohash-sha256/Makefile b/security/hs-cryptohash-sha256/Makefile
index 8ee2e0d234ff..f7126f9d1212 100644
--- a/security/hs-cryptohash-sha256/Makefile
+++ b/security/hs-cryptohash-sha256/Makefile
@@ -10,5 +10,8 @@ COMMENT= A practical incremental and one-pass, pure API to the SHA-256 has
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-cryptohash/Makefile b/security/hs-cryptohash/Makefile
index f81443137f79..79259cb921ec 100644
--- a/security/hs-cryptohash/Makefile
+++ b/security/hs-cryptohash/Makefile
@@ -10,6 +10,9 @@ COMMENT= Collection of crypto hashes, fast, pure, and practical
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= byteable cryptonite>=0.13
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-cryptonite-conduit/Makefile b/security/hs-cryptonite-conduit/Makefile
index c89417144b2d..76f9c34399c6 100644
--- a/security/hs-cryptonite-conduit/Makefile
+++ b/security/hs-cryptonite-conduit/Makefile
@@ -10,6 +10,9 @@ COMMENT= Cryptonite conduit
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= conduit conduit-extra cryptonite resourcet
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-cryptonite/Makefile b/security/hs-cryptonite/Makefile
index 8addff120ced..439a8cc992ec 100644
--- a/security/hs-cryptonite/Makefile
+++ b/security/hs-cryptonite/Makefile
@@ -10,6 +10,9 @@ COMMENT= Cryptography Primitives sink
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= memory>=0.2
FLAGS_ENABLE= support_aesni support_rdrand integer-gmp support_deepseq
diff --git a/security/hs-digest/Makefile b/security/hs-digest/Makefile
index 28cca4f41d11..0dab29f4119a 100644
--- a/security/hs-digest/Makefile
+++ b/security/hs-digest/Makefile
@@ -10,6 +10,9 @@ COMMENT= Various cryptographic hashes for Bytestrings
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= zlib
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-ed25519/Makefile b/security/hs-ed25519/Makefile
index 9dc7024add4c..c60c5ec7b081 100644
--- a/security/hs-ed25519/Makefile
+++ b/security/hs-ed25519/Makefile
@@ -10,5 +10,8 @@ COMMENT= A simple, fast, self-contained copy of the Ed25519 public-key signature
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-entropy/Makefile b/security/hs-entropy/Makefile
index 094a6e8db728..dad77f4f4b9d 100644
--- a/security/hs-entropy/Makefile
+++ b/security/hs-entropy/Makefile
@@ -10,5 +10,8 @@ COMMENT= Platform-independent entropy source
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-gnutls/Makefile b/security/hs-gnutls/Makefile
index 12601048d0a3..a0fb58bc9013 100644
--- a/security/hs-gnutls/Makefile
+++ b/security/hs-gnutls/Makefile
@@ -10,6 +10,9 @@ COMMENT= Bindings for GNU libgnutls
LICENSE= GPLv3
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= monads-tf>=0.1.0
USES= pkgconfig
diff --git a/security/hs-hackage-security/Makefile b/security/hs-hackage-security/Makefile
index aac6c69fc53f..074545e63816 100644
--- a/security/hs-hackage-security/Makefile
+++ b/security/hs-hackage-security/Makefile
@@ -10,6 +10,9 @@ COMMENT= The hackage security library provides both server and client utilities
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= base16-bytestring base64-bytestring cryptohash-sha256 ed25519 \
mtl network network-uri old-locale old-time tar zlib
diff --git a/security/hs-monadcryptorandom/Makefile b/security/hs-monadcryptorandom/Makefile
index 1edd880a88d1..a3e99d5974e4 100644
--- a/security/hs-monadcryptorandom/Makefile
+++ b/security/hs-monadcryptorandom/Makefile
@@ -10,6 +10,9 @@ COMMENT= Monad for using CryptoRandomGen
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= crypto-api exceptions tagged transformers-compat
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-nonce/Makefile b/security/hs-nonce/Makefile
index a069b881bfc7..6149d2257678 100644
--- a/security/hs-nonce/Makefile
+++ b/security/hs-nonce/Makefile
@@ -10,6 +10,9 @@ COMMENT= Generate cryptographic nonces
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= base64-bytestring cprng-aes>=0.5 crypto-random entropy>=0.3.7 \
unliftio
diff --git a/security/hs-pem/Makefile b/security/hs-pem/Makefile
index d14b31c596d8..ec39d2412262 100644
--- a/security/hs-pem/Makefile
+++ b/security/hs-pem/Makefile
@@ -10,6 +10,9 @@ COMMENT= Privacy Enhanced Mail (PEM) format reader and writer
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= base64-bytestring>=1.0.0 mtl
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-pureMD5/Makefile b/security/hs-pureMD5/Makefile
index 01e76bdc3ec3..dbbced3d5c9e 100644
--- a/security/hs-pureMD5/Makefile
+++ b/security/hs-pureMD5/Makefile
@@ -10,6 +10,9 @@ COMMENT= Haskell-only implementation of MD5 digest (hash) yalgorithm
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= cereal>=0.2 crypto-api tagged
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-pwstore-fast/Makefile b/security/hs-pwstore-fast/Makefile
index 12d039d1ea6a..722b31bb3144 100644
--- a/security/hs-pwstore-fast/Makefile
+++ b/security/hs-pwstore-fast/Makefile
@@ -10,6 +10,9 @@ COMMENT= Secure password storage
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= base64-bytestring>=0.1 byteable>=0.1 cryptohash>=0.6 random>=1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-skein/Makefile b/security/hs-skein/Makefile
index 45b3b131e291..1b3469bc6ccf 100644
--- a/security/hs-skein/Makefile
+++ b/security/hs-skein/Makefile
@@ -10,6 +10,9 @@ COMMENT= Skein, a family of cryptographic hash functions
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= cereal>=0.3 crypto-api>=0.6 tagged>=0.2
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-tls-session-manager/Makefile b/security/hs-tls-session-manager/Makefile
index a385e264a73c..33804c4e9f59 100644
--- a/security/hs-tls-session-manager/Makefile
+++ b/security/hs-tls-session-manager/Makefile
@@ -10,6 +10,9 @@ COMMENT= TLS session manager with limitation, automatic pruning, energy saving a
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= auto-update clock psqueues tls
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-tls/Makefile b/security/hs-tls/Makefile
index f4747578edbd..d41cb913b573 100644
--- a/security/hs-tls/Makefile
+++ b/security/hs-tls/Makefile
@@ -10,6 +10,9 @@ COMMENT= TLS/SSL protocol native implementation (Server and Client)
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= asn1-encoding asn1-types>=0.2.0 async byteable cereal>=0.4 \
cryptonite>=0.3 data-default-class memory mtl network \
x509>=1.6 x509-store>=1.6 x509-validation>=1.6
diff --git a/security/hs-x509-store/Makefile b/security/hs-x509-store/Makefile
index 1809cb4d8a63..976170fbf1bb 100644
--- a/security/hs-x509-store/Makefile
+++ b/security/hs-x509-store/Makefile
@@ -10,6 +10,9 @@ COMMENT= X.509 collection accessing and storing methods
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= asn1-encoding>=0.9 asn1-types>=0.3 cryptonite mtl pem>=0.1 \
x509>=1.6
diff --git a/security/hs-x509-system/Makefile b/security/hs-x509-system/Makefile
index 7f64e4916c85..872b8c32cdf9 100644
--- a/security/hs-x509-system/Makefile
+++ b/security/hs-x509-system/Makefile
@@ -10,6 +10,9 @@ COMMENT= Handle per-operating-system X.509 accessors and storage
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= mtl pem>=0.1 x509>=1.6 x509-store>=1.6
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/security/hs-x509-validation/Makefile b/security/hs-x509-validation/Makefile
index 427e84dd3968..ffbaa2509179 100644
--- a/security/hs-x509-validation/Makefile
+++ b/security/hs-x509-validation/Makefile
@@ -10,6 +10,9 @@ COMMENT= X.509 Certificate and CRL validation
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= asn1-encoding>=0.9 asn1-types>=0.3 byteable cryptonite>=0.3 \
data-default-class hourglass memory mtl network pem>=0.1 \
x509>=1.6 x509-store>=1.6
diff --git a/security/hs-x509/Makefile b/security/hs-x509/Makefile
index b0ced0f0bb9c..ddb1ccde4085 100644
--- a/security/hs-x509/Makefile
+++ b/security/hs-x509/Makefile
@@ -10,6 +10,9 @@ COMMENT= X509 reader and writer
LICENSE= BSD3CLAUSE
+DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
+EXPIRATION_DATE= 2019-04-14
+
USE_CABAL= asn1-encoding>=0.9 asn1-parse>=0.9 asn1-types>=0.3.0 \
cryptonite hourglass memory mtl pem>=0.1