aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/p5-openxpki/Makefile49
-rw-r--r--security/p5-openxpki/distinfo4
-rw-r--r--security/p5-openxpki/files/openxpki.in36
-rw-r--r--security/p5-openxpki/files/pkg-message.in33
-rw-r--r--security/p5-openxpki/pkg-descr3
-rw-r--r--security/p5-openxpki/pkg-message10
-rw-r--r--security/p5-openxpki/pkg-plist213
7 files changed, 242 insertions, 106 deletions
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index 0ade9d7762cf..59d899d7b0ea 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -2,17 +2,19 @@
# $FreeBSD$
PORTNAME= openxpki
-PORTVERSION= 0.21.0.1
+PORTVERSION= 0.23.0.1
CATEGORIES= security perl5
PKGNAMEPREFIX= p5-
DIST_SUBDIR= openxpki
MAINTAINER= svysh.fbsd@gmail.com
-COMMENT= Perl based trustcenter software for PKI: server and deployment
+COMMENT= Perl based trustcenter for PKI: universal server building block
LICENSE= APACHE20
BUILD_DEPENDS= \
+ p5-Test-Prereq>=0:${PORTSDIR}/devel/p5-Test-Prereq \
+ p5-Config-GitLike>=0:${PORTSDIR}/devel/p5-Config-GitLike \
p5-openxpki-i18n>=0.20.0.1:${PORTSDIR}/security/p5-openxpki-i18n \
openca-tools-forked>=1.4.0:${PORTSDIR}/security/openca-tools-forked \
p5-Class-Accessor-Chained>=0:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
@@ -56,7 +58,10 @@ BUILD_DEPENDS= \
p5-Config-Std>=0:${PORTSDIR}/devel/p5-Config-Std \
p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
p5-NetAddr-IP>=0:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
- bash:${PORTSDIR}/shells/bash
+ p5-DBD-Mock>=0:${PORTSDIR}/databases/p5-DBD-Mock \
+ p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC \
+ bash:${PORTSDIR}/shells/bash \
+
RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= \
@@ -69,19 +74,22 @@ USE_GITHUB= yes
GH_ACCOUNT= openxpki
GH_PROJECT= openxpki
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 908559d
+GH_COMMIT= ec42128
USE_OPENSSL= yes
USE_PERL5= configure
USES= gmake perl5
USE_RC_SUBR= openxpki
+SUB_FILES= pkg-message
+PORTDOCS= *
WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/core/server
USERS= openxpki
GROUPS= openxpki
+NO_ARCH= yes
-OPTIONS_DEFINE= GRAPHVIZ
+OPTIONS_DEFINE= GRAPHVIZ DOCS
GRAPHVIZ_DESC= With graphical visualization of workflows?
GRAPHVIZ_RUN_DEPENDS= ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz \
@@ -89,8 +97,33 @@ GRAPHVIZ_RUN_DEPENDS= ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz \
post-patch:
@${REINPLACE_CMD} -e 's|..vergen --format version.|"${PORTVERSION:R}"|g' ${WRKSRC}/Makefile.PL
+ @${RM} -f ${WRKSRC}/Makefile.PL.bak
+ @( \
+ cd ${WRKSRC}/../..; \
+ for f in `${FIND} config core/server doc qatest tools -type f ! -path "core/server/t/*"`; do \
+ ${REINPLACE_CMD} -e 's|/etc/openxpki|${PREFIX}/etc/openxpki|g' $${f}; \
+ ${REINPLACE_CMD} -e 's|/var/run/openxpkid.pid|/var/openxpki/openxpkid.pid|g' $${f}; \
+ ${REINPLACE_CMD} -e 's|/var/openxpki/\([^\.]*\)\.log|/var/log/openxpki/\1\.log|g' $${f}; \
+ ${RM} -f $${f}.bak; \
+ done \
+ )
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto/OpenXPKI/OpenXPKI.so
+post-stage:
+ @${MKDIR} ${STAGEDIR}/var/openxpki
+ @${MKDIR} ${STAGEDIR}/var/openxpki/session
+ @${MKDIR} ${STAGEDIR}/var/log/openxpki
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/openxpki
+
+pre-install: test
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto/OpenXPKI/OpenXPKI.so
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/../../config && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+. if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/../../doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+. endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-openxpki/distinfo b/security/p5-openxpki/distinfo
index 11f47ff9d473..439cd2c8c6af 100644
--- a/security/p5-openxpki/distinfo
+++ b/security/p5-openxpki/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openxpki/openxpki-0.21.0.1.tar.gz) = de31c09d26aeb59ea449be4fd3ec90827742dacd6d0bcbb2c53027d142d5fd31
-SIZE (openxpki/openxpki-0.21.0.1.tar.gz) = 2144764
+SHA256 (openxpki/openxpki-0.23.0.1.tar.gz) = b8bcbff15126b83a25ce183aec9fc807ee919ebf9224e7b9b6f3a76d95bad5a6
+SIZE (openxpki/openxpki-0.23.0.1.tar.gz) = 2141438
diff --git a/security/p5-openxpki/files/openxpki.in b/security/p5-openxpki/files/openxpki.in
index e35e316ea2b3..b5507ed6eaf5 100644
--- a/security/p5-openxpki/files/openxpki.in
+++ b/security/p5-openxpki/files/openxpki.in
@@ -1,15 +1,18 @@
#!/bin/sh
# $FreeBSD$
-
+#
# PROVIDE: openxpki
# REQUIRE: LOGIN
# REQUIRE: postgresql
# REQUIRE: mysql
# KEYWORD: shutdown
-
-# Define this variable in the file /etc/rc.conf:
+#
+# Define this variable in file /etc/rc.conf:
# openxpki_enable="YES"
# to ensure that openxpki starts at boot time.
+# Define and edit this variable in file /etc/rc.conf:
+# openxpki_conf="/usr/local/etc/openxpki/config.git"
+# if your configuration is in different place.
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
# SET THEM IN THE /etc/rc.conf FILE
@@ -18,15 +21,26 @@
. /etc/rc.subr
name=openxpki
+desc="OpenXPKI daemon"
rcvar=openxpki_enable
-load_rc_config $name
-command="%%PREFIX%%/bin/openxpkictl"
-
-openxpki_enable="${openxpki_enable-NO}"
-openxpki_pidfile="%%PREFIX%%/var/openxpki/openxpki.pid"
-
+load_rc_config ${name}
+: ${openxpki_enable:=no}
+: ${openxpki_conf=%%PREFIX%%/etc/openxpki/config.git}
+command=%%PREFIX%%/bin/openxpkictl
procname=openxpkid
-
-pidfile=${openxpki_pidfile}
+openxpki_user=${name}
+pidfile=/var/openxpki/openxpkid.pid
+
+extra_commands=reload
+start_cmd=control
+stop_cmd=control
+restart_cmd=control
+status_cmd=control
+reload_cmd=control
+
+control()
+{
+ USER=${openxpki_user} ${command} --config ${openxpki_conf} ${rc_arg}
+}
run_rc_command "$1"
diff --git a/security/p5-openxpki/files/pkg-message.in b/security/p5-openxpki/files/pkg-message.in
new file mode 100644
index 000000000000..a86c60fc4b06
--- /dev/null
+++ b/security/p5-openxpki/files/pkg-message.in
@@ -0,0 +1,33 @@
+==================================================================
+- Universal server building block (OpenXPKI) for arbitrary PKI installed.
+- SCEP prerequisite binary and i18n tools for UI installed.
+- Enable utf8 locale (e.g. en_US.utf8) for the translation staff to operate
+ (translation is needed even for English language).
+- Install your favorite database (enable utf8 support),
+ e.g. databases/mysql56-server
+ Install perl interface for your favorite database,
+ e.g. databases/p5-DBD-mysql
+- Install your favorite web server.
+ This port has created user:group as openxpki:openxpki
+ Add a line: "User openxpki" to configuration of your OpenXPKI-related
+ web server. Choose from two versions of the handler: based on CGI or FastCGI
+ perl core modules.
+- Perform deployment procedure for OpenXPKI in a regular way,
+ without this OpenXPKI server would not start.
+- Start daemons in this order:
+ database server,
+ OpenXPKI server (%%PREFIX%%/etc/rc.d/openxpki start),
+ web server.
+- Docs installed (if you opted so) into %%DOCSDIR%%
+- If you want your PKI server to act as the simplest CA,
+ then copy sample configuration for this case with
+ cp -R %%EXAMPLESDIR%%/openxpki/* %%PREFIX%%/etc/openxpki/
+ and follow advice at:
+ https://openxpki.readthedocs.org/en/latest/quickstart.html
+- Mind FreeBSD specific file structure:
+ %%PREFIX%%/etc/openxpki: server configuration, logs configuration.
+ /var/openxpki: pid file, socket file, ...
+ /var/openxpki/session: session files.
+ /var/log/openxpki: server log files.
+ /var/tmp: temporary directory.
+==================================================================
diff --git a/security/p5-openxpki/pkg-descr b/security/p5-openxpki/pkg-descr
index 553624d809a7..cf10bc39fdc5 100644
--- a/security/p5-openxpki/pkg-descr
+++ b/security/p5-openxpki/pkg-descr
@@ -1,4 +1,3 @@
-Perl based trustcenter for arbitrary complex PKI:
-server and client parts.
+Perl based trustcenter software for PKI: universal server building block
WWW: http://www.openxpki.org
diff --git a/security/p5-openxpki/pkg-message b/security/p5-openxpki/pkg-message
deleted file mode 100644
index 0bb125236536..000000000000
--- a/security/p5-openxpki/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
-==================================================================
-- SCEP prerequisite binary and i18n tools for UI installed.
-- Enable utf8 locale (e.g. en_US.utf8) for the translation staff to operate
- (translation is needed even for English language).
-- Install your favorite database (enable utf8 support) and a web server.
-- Perform deployment procedure for OpenXPKI in a regular way.
-- This port has created user:group as openxpki:openxpki for use with OpenXPKI server.
- Add a line: "User openxpki" to configuration of your OpenXPKI-related web server.
-- Choose from two versions of the handler: based on CGI or FastCGI modules of perl.
-==================================================================
diff --git a/security/p5-openxpki/pkg-plist b/security/p5-openxpki/pkg-plist
index 88a083801df0..4e6c0527a84f 100644
--- a/security/p5-openxpki/pkg-plist
+++ b/security/p5-openxpki/pkg-plist
@@ -275,6 +275,7 @@ bin/openxpkictl
%%PERL5_MAN3%%/OpenXPKI::Server::Workflow::Validator::SPKAC.3.gz
%%PERL5_MAN3%%/OpenXPKI::Server::Workflow::Validator::SmartcardPINUnblockAuthIDs.3.gz
%%PERL5_MAN3%%/OpenXPKI::Server::Workflow::Validator::ValidityTime.3.gz
+%%PERL5_MAN3%%/OpenXPKI::Server::Workflow::Validator::ValidityWindow.3.gz
%%PERL5_MAN3%%/OpenXPKI::Server::Workflow::WFObject.3.gz
%%PERL5_MAN3%%/OpenXPKI::Server::Workflow::WFObject::WFArray.3.gz
%%PERL5_MAN3%%/OpenXPKI::Server::Workflow::WFObject::WFHash.3.gz
@@ -595,6 +596,7 @@ bin/openxpkictl
%%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Validator/SPKAC.pm
%%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Validator/SmartcardPINUnblockAuthIDs.pm
%%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Validator/ValidityTime.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Validator/ValidityWindow.pm
%%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/WFObject.pm
%%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/WFObject/WFArray.pm
%%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/WFObject/WFHash.pm
@@ -626,76 +628,141 @@ man/man1/openxpkiadm.1.gz
man/man1/openxpkicli.1.gz
man/man1/openxpkicmd.1.gz
man/man1/openxpkictl.1.gz
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Client/UI/Handle
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Client/UI
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Client
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Config
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Connector
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Backend/OpenSSL/Command/create_key
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Backend/OpenSSL/Command
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Backend/OpenSSL/Engine
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Backend/OpenSSL/XS
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Backend/OpenSSL
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Backend
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Profile
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Secret
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Tool/CreateJavaKeystore/Command
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Tool/CreateJavaKeystore/Engine
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Tool/CreateJavaKeystore
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Tool/SCEP/Command
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Tool/SCEP/Engine
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Tool/SCEP
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto/Tool
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Crypto
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/SOAP
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Serialization
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/API
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Authentication
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/DBI/Driver
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/DBI
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Log/Appender
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Log
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Notification
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Session
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Watchdog
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/CRLIssuance
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/CRR
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/CSR
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/CertIssuance
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/CertRenewal
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/NICE
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/Reports/CertExport
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/Reports
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/SCEPv2
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/SmartCard
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/Tools/Connector
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/Tools/Datapool
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/Tools
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity/Transfer
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Activity
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Condition/Connector
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Condition/NICE
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Condition/SCEPv2
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Condition/Smartcard
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Condition
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/NICE
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Observer
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Persister/DBI
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Persister
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/Validator
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow/WFObject
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server/Workflow
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Server
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Service/Default/Command
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Service/Default
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Service/SCEP/Command
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Service/SCEP
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Service
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Template/Plugin
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Template
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Test
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Transport
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/Workflow
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI/XML
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenXPKI
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/apache/openxpki-scep.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/_workflow/workflow_activity_smartcard_personalization_v4.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/_workflow/workflow_activity_smartcard_pin_unblock.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/_workflow/workflow_condition_smartcard_personalization_v4.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/_workflow/workflow_condition_smartcard_pin_unblock.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/_workflow/workflow_def_smartcard_personalization_v4.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/_workflow/workflow_def_smartcard_pin_unblock.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/_workflow/workflow_validator_smartcard_personalization_v4.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/profile/I18N_OPENXPKI_PROFILE_USER_AUTHENTICATION_NOMAIL.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/profile/I18N_OPENXPKI_PROFILE_USER_ENCRYPTION.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/profile/I18N_OPENXPKI_PROFILE_USER_SIGNATURE.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/smartcard/card2user.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/smartcard/cardinfo.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/smartcard/cardstatus.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/smartcard/employee.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/smartcard/groupinfo.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/smartcard/policy.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/smartcard/publishing.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/smartcard/upninfo.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/smartcard/config.d/realm/ca-one/users.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/soap/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/soap/soap/default.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/soap/soap/log.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/config.d/realm/ca-one/_workflow/workflow_activity_cert_export.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/config.d/realm/ca-one/_workflow/workflow_activity_testing.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/config.d/realm/ca-one/_workflow/workflow_condition_cert_export.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/config.d/realm/ca-one/_workflow/workflow_def_cert_export.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/config.d/realm/ca-one/_workflow/workflow_def_testing.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/config.d/realm/ca-one/approval.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/config.d/realm/ca-one/cert_revoke.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/unsorted/config.d/realm/ca-one/export.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/workflow-yaml/config.d/realm/ca-one/workflow/def/test.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/workflow-yaml/config.d/realm/ca-one/workflow/global/action.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/workflow-yaml/config.d/realm/ca-one/workflow/observer.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/feature/workflow-yaml/config.d/realm/ca-one/workflow/persister.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graffle/workflow_certificate_revoke.graffle
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graffle/workflow_enrollment.graffle
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graffle/workflow_ogflow.graffle
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_certificate_publishing.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_certificate_renewal_request.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_certificate_revocation_request.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_certificate_signing_request.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_certificate_signing_request_v2.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_change_metadata.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_crl_issuance.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_enrollment.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_activity_nice.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_condition.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_condition_acl.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_condition_enrollment.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_condition_nice.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_certificate_publishing.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_certificate_renewal_request.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_certificate_revocation_request.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_certificate_revocation_request_v2.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_certificate_signing_request.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_certificate_signing_request_v2.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_change_metadata.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_crl_issuance.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_def_enrollment.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_validator.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_validator_certificate_revocation_request.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_validator_certificate_signing_request.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_validator_change_metadata.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/_workflow/workflow_validator_enrollment.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/auth/connector.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/auth/handler.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/auth/roles.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/auth/stack.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/auth/wfacl.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/crl/default.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/crypto.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/metadata.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/nice.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/notification/rt.yaml.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/notification/servicenow.yaml.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/notification/smtp.yaml.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/profile/I18N_OPENXPKI_PROFILE_TLS_SERVER.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/profile/I18N_OPENXPKI_PROFILE_USER.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/profile/default.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/profile/sample.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/profile/template.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/publishing.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/realm/ca-one/scep/scep-server-1.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/system/crypto.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/system/database.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/system/realms.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/system/server.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/config.d/system/watchdog.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/log.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/cert_issued.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/cert_issued.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/csr_created_raop.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/csr_created_user.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/csr_created_user.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/csr_rejected.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/csr_rejected.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/images/.keep
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/images/foot.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/images/head.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_approval_pending_raop.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_approval_pending_requestor.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_approval_pending_requestor.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_approval_rejected.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_approval_rejected.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_auth_denied.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_auth_denied.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_cert_issued.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scep_cert_issued.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scpu_notify_authcontact.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/scpu_notify_user.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/testmail.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/email/testmail.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/rt/cert_issued.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/rt/cert_issued_internal.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/rt/csr_approvers.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/rt/csr_created.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/rt/csr_created_comment.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/rt/csr_rejected.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/notification/rt/test.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/scep/default.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/scep/log.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/ssl/ca-one/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/openxpki/webui/log.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/profiles/I18N_OPENXPKI_PROFILE_OPENVPN_CLIENT.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/profiles/I18N_OPENXPKI_PROFILE_SCEP_CLIENT.yaml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampleconfig.sh
+@owner openxpki
+@group openxpki
+@dir %%ETCDIR%%
+@dir /var/openxpki/session
+@dir /var/openxpki
+@dir /var/log/openxpki