aboutsummaryrefslogtreecommitdiffstats
path: root/shells/zsh-autosuggestions/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/zsh-autosuggestions/Makefile')
-rw-r--r--shells/zsh-autosuggestions/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/shells/zsh-autosuggestions/Makefile b/shells/zsh-autosuggestions/Makefile
new file mode 100644
index 000000000000..79071faf6670
--- /dev/null
+++ b/shells/zsh-autosuggestions/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= zsh-autosuggestions
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5.2
+CATEGORIES= textproc
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Fish-like autosuggestions for Zsh
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= zsh>=4.3:shells/zsh
+
+USE_GITHUB= yes
+GH_ACCOUNT= zsh-users
+
+NO_ARCH= yes
+NO_BUILD= yes
+PLIST_FILES= ${DATADIR}/${PORTNAME}.zsh
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/zsh-autosuggestions.zsh ${STAGEDIR}/${DATADIR}
+
+.include <bsd.port.mk>