aboutsummaryrefslogtreecommitdiffstats
path: root/shells/zsh
diff options
context:
space:
mode:
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile2
-rw-r--r--shells/zsh/files/patch-Src::utils.c8
2 files changed, 9 insertions, 1 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 241ae461623d..62778c2df5de 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -32,7 +32,7 @@ ZSH_VER= ${PORTVERSION}
ZSHFUNC_SUBDIR= share/zsh/${ZSH_VER}/functions
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-zsh-mem --enable-zsh-secure-free --enable-dynamic \
- --enable-maildir-support
+ --enable-maildir-support --with-curses-terminfo
.if !defined(NOPORTDOCS)
INSTALL_TARGET= install install.html
diff --git a/shells/zsh/files/patch-Src::utils.c b/shells/zsh/files/patch-Src::utils.c
new file mode 100644
index 000000000000..189d6392231c
--- /dev/null
+++ b/shells/zsh/files/patch-Src::utils.c
@@ -0,0 +1,8 @@
+--- Src/utils.c.orig Wed Dec 4 19:39:01 2002
++++ Src/utils.c Wed Dec 4 19:39:18 2002
+@@ -1093,4 +1093,5 @@
+ * is unique, for use as a temporary file. */
+
++extern char *_mktemp(char *);
+ /**/
+ mod_export char *