aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/archivemount/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/archivemount/Makefile')
-rw-r--r--sysutils/archivemount/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/archivemount/Makefile b/sysutils/archivemount/Makefile
new file mode 100644
index 000000000000..e1b398bee441
--- /dev/null
+++ b/sysutils/archivemount/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: archivemount
+# Date created: 2008-06-20
+# Whom: Evgeny Zhirnov <jirnov@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= archivemount
+PORTVERSION= 0.5.3
+CATEGORIES= sysutils
+MASTER_SITES= http://www.cybernoia.de/software/archivemount/
+
+MAINTAINER= jirnov@gmail.com
+COMMENT= Mount archives with FUSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+PLIST_FILES= bin/archivemount
+
+NO_INSTALL_MANPAGES= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_GCC= 4.2+
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/archivemount ${PREFIX}/bin
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 # Inherited from fusefs-kmod
+IGNORE= requires FreeBSD 6.x or above
+.endif
+
+.include <bsd.port.post.mk>