aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/baloo/files
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/baloo/files')
-rw-r--r--sysutils/baloo/files/patch-CMakeLists.txt11
-rw-r--r--sysutils/baloo/files/patch-src__file__lib__baloo_xattr_p.h11
2 files changed, 22 insertions, 0 deletions
diff --git a/sysutils/baloo/files/patch-CMakeLists.txt b/sysutils/baloo/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ab193b25bd3a
--- /dev/null
+++ b/sysutils/baloo/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2014-09-15 21:59:21.923468081 +0200
++++ CMakeLists.txt 2014-09-15 21:59:30.538469102 +0200
+@@ -2,7 +2,7 @@
+
+ set(BALOO_VERSION_MAJOR 4)
+ set(BALOO_VERSION_MINOR 14)
+-set(BALOO_VERSION_RELEASE 0)
++set(BALOO_VERSION_RELEASE 2)
+ set(BALOO_VERSION "${BALOO_VERSION_MAJOR}.${BALOO_VERSION_MINOR}.${BALOO_VERSION_RELEASE}")
+
+ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" ${CMAKE_MODULE_PATH})
diff --git a/sysutils/baloo/files/patch-src__file__lib__baloo_xattr_p.h b/sysutils/baloo/files/patch-src__file__lib__baloo_xattr_p.h
new file mode 100644
index 000000000000..bda9070d2188
--- /dev/null
+++ b/sysutils/baloo/files/patch-src__file__lib__baloo_xattr_p.h
@@ -0,0 +1,11 @@
+--- src/file/lib/baloo_xattr_p.h.orig 2014-08-21 13:16:09.854553785 +0200
++++ src/file/lib/baloo_xattr_p.h 2014-08-21 13:16:53.727550878 +0200
+@@ -117,7 +117,7 @@
+ #elif defined(Q_OS_MAC)
+ return removexattr(encodedPath, attributeName, XATTR_NOFOLLOW );
+ #elif defined(Q_OS_FREEBSD) || defined(Q_OS_NETBSD)
+- return removexattr (encodedPath, attributeName);
++ return extattr_delete_file (encodedPath, EXTATTR_NAMESPACE_USER, attributeName);
+ #else
+ return -1;
+ #endif