aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cfengine35/files
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/cfengine35/files')
-rw-r--r--sysutils/cfengine35/files/cf-execd.in28
-rw-r--r--sysutils/cfengine35/files/cf-monitord.in28
-rw-r--r--sysutils/cfengine35/files/cf-serverd.in28
-rw-r--r--sysutils/cfengine35/files/patch-cf-agent-Makefile.in11
-rw-r--r--sysutils/cfengine35/files/patch-libpromises-expand.c10
-rw-r--r--sysutils/cfengine35/files/patch-libpromises-sysinfo.c13
6 files changed, 0 insertions, 118 deletions
diff --git a/sysutils/cfengine35/files/cf-execd.in b/sysutils/cfengine35/files/cf-execd.in
deleted file mode 100644
index 1ee33104e76e..000000000000
--- a/sysutils/cfengine35/files/cf-execd.in
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: cf-execd
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following line to /etc/rc.conf[.local] to enable cf-execd(8)
-#
-# cf_execd_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable cf-execd.
-# cf_execd_flags (str): Custom additional arguments to be passed
-# to cf-execd (default empty).
-#
-
-. /etc/rc.subr
-
-name="cf_execd"
-rcvar=cf_execd_enable
-
-command="%%PREFIX%%/sbin/cf-execd"
-
-load_rc_config $name
-
-: ${cf_execd_enable="NO"}
-
-run_rc_command "$1"
diff --git a/sysutils/cfengine35/files/cf-monitord.in b/sysutils/cfengine35/files/cf-monitord.in
deleted file mode 100644
index 471ee108622a..000000000000
--- a/sysutils/cfengine35/files/cf-monitord.in
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: cf-monitord
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following line to /etc/rc.conf[.local] to enable cf-monitord(8)
-#
-# cf_monitord_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable cf-monitord.
-# cf_monitord_flags (str): Custom additional arguments to be passed
-# to cf-monitord (default empty).
-#
-
-. /etc/rc.subr
-
-name="cf_monitord"
-rcvar=cf_monitord_enable
-
-command="%%PREFIX%%/sbin/cf-monitord"
-
-load_rc_config $name
-
-: ${cf_monitord_enable="NO"}
-
-run_rc_command "$1"
diff --git a/sysutils/cfengine35/files/cf-serverd.in b/sysutils/cfengine35/files/cf-serverd.in
deleted file mode 100644
index 9fbd07cc148a..000000000000
--- a/sysutils/cfengine35/files/cf-serverd.in
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: cf-serverd
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following line to /etc/rc.conf[.local] to enable cf-serverd(8)
-#
-# cf_serverd_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable cf-serverd.
-# cf_serverd_flags (str): Custom additional arguments to be passed
-# to cf-serverd (default empty).
-#
-
-. /etc/rc.subr
-
-name="cf_serverd"
-rcvar=cf_serverd_enable
-
-command="%%PREFIX%%/sbin/cf-serverd"
-
-load_rc_config $name
-
-: ${cf_serverd_enable="NO"}
-
-run_rc_command "$1"
diff --git a/sysutils/cfengine35/files/patch-cf-agent-Makefile.in b/sysutils/cfengine35/files/patch-cf-agent-Makefile.in
deleted file mode 100644
index 1e6ac04c3b61..000000000000
--- a/sysutils/cfengine35/files/patch-cf-agent-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- cf-agent/Makefile.in.orig 2013-06-12 09:10:17.000000000 -0400
-+++ cf-agent/Makefile.in 2013-06-12 13:17:39.103623377 -0400
-@@ -53,7 +53,7 @@
- target_triplet = @target@
- sbin_PROGRAMS = cf-agent$(EXEEXT)
- @HAVE_NOVA_TRUE@am__append_1 = -I$(abs_top_srcdir)/nova/libcfagent
--@HAVE_AVAHI_CLIENT_TRUE@@HAVE_AVAHI_COMMON_TRUE@am__append_2 = -ldl
-+@HAVE_AVAHI_CLIENT_TRUE@@HAVE_AVAHI_COMMON_TRUE@am__append_2 =
- @HAVE_NOVA_TRUE@am__append_3 = ../nova/libcfagent/libcfagent.la
- @NT_FALSE@am__append_4 = nfs.c nfs.h
- @HAVE_NOVA_FALSE@am__append_5 = cf-agent-enterprise-stubs.c cf-agent-enterprise-stubs.h
diff --git a/sysutils/cfengine35/files/patch-libpromises-expand.c b/sysutils/cfengine35/files/patch-libpromises-expand.c
deleted file mode 100644
index 49890fdd3813..000000000000
--- a/sysutils/cfengine35/files/patch-libpromises-expand.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libpromises/expand.c.orig 2014-03-31 18:24:39.000000000 +0000
-+++ libpromises/expand.c 2014-03-31 18:25:10.000000000 +0000
-@@ -787,6 +787,7 @@
- ScopeNewSpecial(ctx, "this", "promise_linenumber", number, DATA_TYPE_STRING);
- }
-
-+ ScopeNewSpecial(ctx, "this", "promiser", pp->promiser, DATA_TYPE_STRING);
- snprintf(v, CF_MAXVARSIZE, "%d", (int) getuid());
- ScopeNewSpecial(ctx, "this", "promiser_uid", v, DATA_TYPE_INT);
- snprintf(v, CF_MAXVARSIZE, "%d", (int) getgid());
diff --git a/sysutils/cfengine35/files/patch-libpromises-sysinfo.c b/sysutils/cfengine35/files/patch-libpromises-sysinfo.c
deleted file mode 100644
index eb7e2704228f..000000000000
--- a/sysutils/cfengine35/files/patch-libpromises-sysinfo.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- libpromises/sysinfo.c.orig 2013-12-09 12:13:14.000000000 +0000
-+++ libpromises/sysinfo.c 2014-03-25 14:30:28.000000000 +0000
-@@ -1075,6 +1075,10 @@
- {
- snprintf(vbuff, CF_BUFSIZE, "/var/spool/cron/%s", pw->pw_name);
- }
-+ else if (IsDefinedClass(ctx, "freebsd", NULL))
-+ {
-+ snprintf(vbuff, CF_BUFSIZE, "/var/cron/tabs/%s", pw->pw_name);
-+ }
- else
- {
- snprintf(vbuff, CF_BUFSIZE, "/var/spool/cron/crontabs/%s", pw->pw_name);