aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/firstboot-pkgs
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/firstboot-pkgs')
-rw-r--r--sysutils/firstboot-pkgs/Makefile9
-rw-r--r--sysutils/firstboot-pkgs/files/firstboot_pkgs.in6
2 files changed, 5 insertions, 10 deletions
diff --git a/sysutils/firstboot-pkgs/Makefile b/sysutils/firstboot-pkgs/Makefile
index 6c117eddff39..9d023485c4f7 100644
--- a/sysutils/firstboot-pkgs/Makefile
+++ b/sysutils/firstboot-pkgs/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= firstboot-pkgs
-PORTVERSION= 1.4
+PORTVERSION= 1.5
CATEGORIES= sysutils
MASTER_SITES= # none
DISTFILES= # none
@@ -13,13 +13,8 @@ COMMENT= Install packages when the system first boots
NO_WRKSUBDIR= yes
NO_BUILD= yes
NO_INSTALL= yes
+NO_ARCH= yes
USE_RC_SUBR= firstboot_pkgs
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} < 902504 || ( ${OSVERSION} >= 1000000 && ${OSVERSION} < 1000100 ) || ( ${OSVERSION} >= 1000500 && ${OSVERSION} < 1000501 ) || (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100001 )
-IGNORE= first boot rc.d scripts not supported on this version of FreeBSD
-.endif
-
.include <bsd.port.mk>
diff --git a/sysutils/firstboot-pkgs/files/firstboot_pkgs.in b/sysutils/firstboot-pkgs/files/firstboot_pkgs.in
index 817ae95a8ad8..886ac4221dab 100644
--- a/sysutils/firstboot-pkgs/files/firstboot_pkgs.in
+++ b/sysutils/firstboot-pkgs/files/firstboot_pkgs.in
@@ -37,10 +37,10 @@ firstboot_pkgs_run()
fi
# Install requested packages, if any
- if ! [ -z "$firstboot_pkgs_list" ]; then
- env ASSUME_ALWAYS_YES=YES pkg install $firstboot_pkgs_list </dev/null |
+ for package in ${firstboot_pkgs_list}; do
+ env ASSUME_ALWAYS_YES=YES pkg install ${package} </dev/null |
cat
- fi
+ done
# Count rc.d scripts again
nscriptsn=`ls /usr/local/etc/rc.d | wc -l`