aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/flexbackup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/flexbackup/Makefile')
-rw-r--r--sysutils/flexbackup/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/sysutils/flexbackup/Makefile b/sysutils/flexbackup/Makefile
index c94da0f8ff22..bc48c82f511d 100644
--- a/sysutils/flexbackup/Makefile
+++ b/sysutils/flexbackup/Makefile
@@ -15,6 +15,11 @@ MASTER_SITES= http://www.edwinh.org/flexbackup/tarball/ \
MAINTAINER= mva@sysfault.org
COMMENT= Perl-based flexible backup system that can use dump/afio/cpio/tar/star
+# FreeBSD 6.0 removed gtar
+RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+
+TAR_CMD= ${PREFIX}/bin/gtar
+
MAKE_ARGS= PERLPATH=${PERL} CONFFILE=${PREFIX}/etc/flexbackup.conf
USE_PERL5= yes
@@ -29,17 +34,6 @@ OPTIONS= AFIO "Enable afio support" Off \
.include <bsd.port.pre.mk>
-# Releases previous to 5.3 do not need a special gtar handling as GNU tar
-# is the default here. >= 503001 to < 60022 have GNU tar renamed to gtar
-# under circumstances, thus rely on gtar here. 600022 removed gtar.
-TAR_CMD= /usr/bin/tar
-.if ${OSVERSION} >= 600022
-RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
-TAR_CMD= ${PREFIX}/bin/gtar
-.elif ${OSVERSION} >= 503001 && ${OSVERSION} < 600022
-TAR_CMD= /usr/bin/gtar
-.endif
-
.if defined(WITH_AFIO)
RUN_DEPENDS+= afio:${PORTSDIR}/sysutils/afio
.endif