aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/nvme-cli/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/nvme-cli/Makefile')
-rw-r--r--sysutils/nvme-cli/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/nvme-cli/Makefile b/sysutils/nvme-cli/Makefile
new file mode 100644
index 000000000000..517e8b492347
--- /dev/null
+++ b/sysutils/nvme-cli/Makefile
@@ -0,0 +1,26 @@
+# Created by: imp
+# $FreeBSD$
+
+PORTNAME= nvme-cli
+PORTVERSION= 1.6
+CATEGORIES= sysutils
+
+MAINTAINER= imp@FreeBSD.org
+COMMENT= Port of Linux nvme cli utility
+
+LICENSE= GPLv2
+
+# only tested on amd64, all other archs are no-go until we're sure amd64 works.
+# And there's plenty in amd64 that compiles, but won't run (eg using /sys/, etc)
+ONLY_FOR_ARCHS= amd64
+BROKEN_FreeBSD_11= Uses newer API than in 11.x
+BROKEN_FreeBSD_10= Uses newer API than in 10.x
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= bsdimp
+GH_PROJECT= nvme-cli
+GH_TAGNAME= 9221b5f
+
+.include <bsd.port.mk>