aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/openipmi/files
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/openipmi/files')
-rw-r--r--sysutils/openipmi/files/extra-patch-glib_glib__os__hnd.c33
-rw-r--r--sysutils/openipmi/files/extra-patch-swig_perl_Makefile.in13
-rw-r--r--sysutils/openipmi/files/patch-OpenIPMIpthread.pc.in10
-rw-r--r--sysutils/openipmi/files/patch-configure13
-rw-r--r--sysutils/openipmi/files/patch-lanserv_extcmd.c12
-rw-r--r--sysutils/openipmi/files/patch-lib_rakp.c11
-rw-r--r--sysutils/openipmi/files/patch-swig_perl_Makefile.in11
7 files changed, 55 insertions, 48 deletions
diff --git a/sysutils/openipmi/files/extra-patch-glib_glib__os__hnd.c b/sysutils/openipmi/files/extra-patch-glib_glib__os__hnd.c
new file mode 100644
index 000000000000..9908271e246d
--- /dev/null
+++ b/sysutils/openipmi/files/extra-patch-glib_glib__os__hnd.c
@@ -0,0 +1,33 @@
+--- glib/glib_os_hnd.c.orig 2015-06-25 22:51:39.000000000 +0000
++++ glib/glib_os_hnd.c 2018-07-30 13:30:17.799255000 +0000
+@@ -777,23 +777,21 @@
+ {
+ gint64 now;
+
+- now = g_get_monotonic_time();
+- tv->tv_sec = now / G_TIME_SPAN_SECOND;
+- tv->tv_usec = now % G_TIME_SPAN_SECOND;
++ g_get_current_time(&now);
++ tv->tv_sec = now / 1000000;
++ tv->tv_usec = now % 1000000;
+ return 0;
+ }
+
+ static int get_glib_time(os_handler_t *handler,
+ struct timeval *tv)
+ {
+- GDateTime *now;
++ GTimeVal now;
+ GTimeVal gtv;
+
+- now = g_date_time_new_now_utc();
+- g_date_time_to_timeval(now, &gtv);
+- g_date_time_unref(now);
+- tv->tv_sec = gtv.tv_sec;
+- tv->tv_usec = gtv.tv_usec;
++ g_get_current_time(&now);
++ tv->tv_sec = now.tv_sec;
++ tv->tv_usec = now.tv_usec;
+ return 0;
+ }
+
diff --git a/sysutils/openipmi/files/extra-patch-swig_perl_Makefile.in b/sysutils/openipmi/files/extra-patch-swig_perl_Makefile.in
new file mode 100644
index 000000000000..f9bb8b5697a9
--- /dev/null
+++ b/sysutils/openipmi/files/extra-patch-swig_perl_Makefile.in
@@ -0,0 +1,13 @@
+--- swig/perl/Makefile.in.orig 2018-08-23 20:18:14 UTC
++++ swig/perl/Makefile.in
+@@ -115,8 +115,8 @@
+ am__v_lt_1 =
+ libOpenIPMI_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
+- $(AM_CFLAGS) $(CFLAGS) $(libOpenIPMI_la_LDFLAGS) $(LDFLAGS) -o \
+- $@
++ $(AM_CFLAGS) $(CFLAGS) $(libOpenIPMI_la_LDFLAGS) $(LDFLAGS) \
++ `perl -MConfig -e 'print $$Config{lddlflags}'` -o $@
+ libdummystuff_la_LIBADD =
+ am_libdummystuff_la_OBJECTS = dummystuff.lo
+ libdummystuff_la_OBJECTS = $(am_libdummystuff_la_OBJECTS)
diff --git a/sysutils/openipmi/files/patch-OpenIPMIpthread.pc.in b/sysutils/openipmi/files/patch-OpenIPMIpthread.pc.in
deleted file mode 100644
index 4d5c483f002b..000000000000
--- a/sysutils/openipmi/files/patch-OpenIPMIpthread.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- OpenIPMIpthread.pc.in.orig 2012-07-21 22:01:45 UTC
-+++ OpenIPMIpthread.pc.in
-@@ -6,6 +6,6 @@ includedir=@includedir@
- Name: OpenIPMIpthread
- Description: Pthread OS handler for OpenIPMI
- Version: @VERSION@
--Requires: OpenIPMI pthread
-+Requires: OpenIPMI
- Libs: -L${libdir} -lOpenIPMIutils -lOpenIPMIpthread
- Cflags: -I${includedir}
diff --git a/sysutils/openipmi/files/patch-configure b/sysutils/openipmi/files/patch-configure
deleted file mode 100644
index 07e8d97ea8f2..000000000000
--- a/sysutils/openipmi/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig 2014-01-28 19:35:11 UTC
-+++ configure
-@@ -4206,6 +4206,10 @@ unknown)
- esac
-
-
-+OPENIPMI_VERSION_MAJOR=2
-+OPENIPMI_VERSION_MINOR=0
-+OPENIPMI_VERSION_RELEASE=21
-+OPENIPMI_VERSION_EXTRA=
-
-
- OPENIPMI_SMI=
diff --git a/sysutils/openipmi/files/patch-lanserv_extcmd.c b/sysutils/openipmi/files/patch-lanserv_extcmd.c
index 3fed0d33ab35..6b981c0c252a 100644
--- a/sysutils/openipmi/files/patch-lanserv_extcmd.c
+++ b/sysutils/openipmi/files/patch-lanserv_extcmd.c
@@ -1,14 +1,20 @@
---- lanserv/extcmd.c.orig 2015-07-30 03:31:16 UTC
+--- lanserv/extcmd.c.orig 2018-07-30 08:08:12 UTC
+++ lanserv/extcmd.c
-@@ -52,10 +52,11 @@
- * products derived from this software without specific prior
+@@ -53,16 +53,11 @@
* written permission.
*/
+ #include <config.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
+-#ifdef HAVE_NETINET_ETHER_H
-#include <netinet/ether.h>
+-#elif defined(HAVE_SYS_ETHERNET_H)
+-#include <sys/ethernet.h>
+-#else
+-#error "either netinet/ether.h or sys/ethernet.h must exist."
+-#endif
+#include <net/ethernet.h>
#include <ctype.h>
#include <string.h>
diff --git a/sysutils/openipmi/files/patch-lib_rakp.c b/sysutils/openipmi/files/patch-lib_rakp.c
deleted file mode 100644
index d451e05f34dc..000000000000
--- a/sysutils/openipmi/files/patch-lib_rakp.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/rakp.c.orig 2015-08-19 12:52:44 UTC
-+++ lib/rakp.c
-@@ -482,7 +482,7 @@
- return EINVAL;
- HMAC(rinfo->evp_md, p, rinfo->key_len, idata, 58+idata[57], integ_data, &ilen);
- if (memcmp(data+40, integ_data, rinfo->key_len) != 0)
-- return EKEYREJECTED;
-+ return EAGAIN;
-
- /* Now generate the SIK */
- p = ipmi_rmcpp_auth_get_my_rand(info->ainfo, &plen);
diff --git a/sysutils/openipmi/files/patch-swig_perl_Makefile.in b/sysutils/openipmi/files/patch-swig_perl_Makefile.in
deleted file mode 100644
index 7cfe352372f1..000000000000
--- a/sysutils/openipmi/files/patch-swig_perl_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- swig/perl/Makefile.in.orig 2014-12-04 17:01:40 UTC
-+++ swig/perl/Makefile.in
-@@ -533,7 +533,7 @@ uninstall-am: uninstall-local
- all: OpenIPMI.so
-
- OpenIPMI.so: $(OpenIPMI_OBJ)
-- $(LIBTOOL) --mode=link $(CC) -shared -module -avoid-version -o $(@:.so=.la) $^ $(OPENIPMI_SWIG_LIBS) $(PERL_POSIX_LIB) -rpath $(PERL_INSTALL_DIR)/auto/OpenIPMI
-+ $(LIBTOOL) --mode=link $(CC) -shared -module -avoid-version -o $(@:.so=.la) $^ $(OPENIPMI_SWIG_LIBS) $(PERL_POSIX_LIB) -rpath $(PERL_INSTALL_DIR)/auto/OpenIPMI `perl -MConfig -e 'print $$Config{lddlflags}'`
- rm -f OpenIPMI.so
- mv .libs/OpenIPMI.so .
- rm -rf .libs