aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pax-utils/files
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/pax-utils/files')
-rw-r--r--sysutils/pax-utils/files/patch-Makefile8
-rw-r--r--sysutils/pax-utils/files/patch-scanelf.c13
2 files changed, 17 insertions, 4 deletions
diff --git a/sysutils/pax-utils/files/patch-Makefile b/sysutils/pax-utils/files/patch-Makefile
index 6d7d85f5bfd6..abb2876ce17e 100644
--- a/sysutils/pax-utils/files/patch-Makefile
+++ b/sysutils/pax-utils/files/patch-Makefile
@@ -1,6 +1,6 @@
---- ./Makefile.orig 2010-02-14 19:14:16.000000000 +0100
-+++ ./Makefile 2010-11-12 00:49:47.000000000 +0100
-@@ -21,7 +21,7 @@
+--- ./Makefile.orig 2012-01-24 00:49:40.000000000 +0100
++++ ./Makefile 2012-02-04 04:30:30.000000000 +0100
+@@ -24,7 +24,7 @@
LDFLAGS +=
LIBS :=
DESTDIR =
@@ -9,7 +9,7 @@
STRIP := strip
MKDIR := mkdir -p
CP := cp
-@@ -97,15 +97,15 @@
+@@ -100,15 +100,15 @@
$(STRIP) --strip-unneeded $(TARGETS)
install: all
diff --git a/sysutils/pax-utils/files/patch-scanelf.c b/sysutils/pax-utils/files/patch-scanelf.c
new file mode 100644
index 000000000000..ca6a2e9be4c0
--- /dev/null
+++ b/sysutils/pax-utils/files/patch-scanelf.c
@@ -0,0 +1,13 @@
+--- ./scanelf.c.orig 2012-02-04 05:19:34.000000000 +0100
++++ ./scanelf.c 2012-02-04 05:19:59.000000000 +0100
+@@ -14,6 +14,10 @@
+
+ #define IS_MODIFIER(c) (c == '%' || c == '#' || c == '+')
+
++#ifndef O_CLOEXEC
++#define O_CLOEXEC 0x00100000
++#endif
++
+ /* prototypes */
+ static int file_matches_list(const char *filename, char **matchlist);
+