aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/policykit-gnome/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/policykit-gnome/Makefile')
-rw-r--r--sysutils/policykit-gnome/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/policykit-gnome/Makefile b/sysutils/policykit-gnome/Makefile
new file mode 100644
index 000000000000..95027020488e
--- /dev/null
+++ b/sysutils/policykit-gnome/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: PolicyKit-gnome
+# Date Created: 20 January 2008
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/sysutils/policykit-gnome/Makefile,v 1.4 2008/02/15 16:48:08 mezz Exp $
+#
+
+PORTNAME= policykit-gnome
+PORTVERSION= 0.7
+PORTREVISION= 2
+CATEGORIES= sysutils gnome
+MASTER_SITES= http://hal.freedesktop.org/releases/
+DISTNAME= PolicyKit-gnome-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME frontend to the PolicKit framework
+
+LIB_DEPENDS= polkit.2:${PORTSDIR}/sysutils/policykit \
+ sexy.2:${PORTSDIR}/x11-toolkits/libsexy
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomehack gnometarget gnomevfs2 intlhack gnomedocutils
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-gtk-doc \
+ --localstatedir=/var
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>