aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/sysinfo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/sysinfo/Makefile')
-rw-r--r--sysutils/sysinfo/Makefile47
1 files changed, 16 insertions, 31 deletions
diff --git a/sysutils/sysinfo/Makefile b/sysutils/sysinfo/Makefile
index bcfcdc42adc1..10779f4e1787 100644
--- a/sysutils/sysinfo/Makefile
+++ b/sysutils/sysinfo/Makefile
@@ -3,34 +3,27 @@
PORTNAME= sysinfo
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
+MASTER_SITES= LOCAL/danger \
http://danger.rulez.sk/projects/sysinfo/
-MASTER_SITE_SUBDIR=danger
MAINTAINER= danger@FreeBSD.org
COMMENT= Utility used to gather system configuration information
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAN5= sysinfo.conf.5
-MAN8= sysinfo.8
-
OPTIONS_DEFINE= DMIDECODE PORTAUDIT
-DMIDECODE_DESC= Include information from the dmidecode tool
-PORTAUDIT_DESC= Include information from the portaudit tool
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDMIDECODE}
-RUN_DEPENDS= dmidecode:${PORTSDIR}/sysutils/dmidecode
-.endif
+DMIDECODE_DESC= Include information from the dmidecode tool
+DMIDECODE_RUN_DEPENDS= dmidecode:${PORTSDIR}/sysutils/dmidecode
-.if ${PORT_OPTIONS:MPORTAUDIT}
-RUN_DEPENDS+= portaudit:${PORTSDIR}/ports-mgmt/portaudit
-.endif
+PORTAUDIT_DESC= Include information from the portaudit tool
+PORTAUDIT_RUN_DEPENDS= portaudit:${PORTSDIR}/ports-mgmt/portaudit
post-patch:
@${REINPLACE_CMD} -e 's|common.subr|${DATADIR}/common.subr|g' ${WRKSRC}/sysinfo
@@ -40,20 +33,12 @@ post-patch:
${WRKSRC}/sysinfo.conf ${WRKSRC}/doc/sysinfo.conf.5
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/sysinfo ${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/sysinfo.conf ${PREFIX}/etc/sysinfo.conf.sample
-
-post-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/common.subr ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/LICENCE ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_BIN} modules ${DATADIR})
-
- ${INSTALL_MAN} ${WRKSRC}/doc/sysinfo.conf.5 ${MANPREFIX}/man/man5
- ${INSTALL_MAN} ${WRKSRC}/doc/sysinfo.8 ${MANPREFIX}/man/man8
-
- @if [ ! -f ${PREFIX}/etc/sysinfo.conf ]; then \
- ${CP} -p ${PREFIX}/etc/sysinfo.conf.sample ${PREFIX}/etc/sysinfo.conf ; \
- fi
+ ${INSTALL_SCRIPT} ${WRKSRC}/sysinfo ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/sysinfo.conf ${STAGEDIR}${PREFIX}/etc/sysinfo.conf.sample
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/common.subr ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_BIN} modules ${STAGEDIR}${DATADIR})
+ ${INSTALL_MAN} ${WRKSRC}/doc/sysinfo.conf.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/doc/sysinfo.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
.include <bsd.port.mk>