aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/vagrant
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/vagrant')
-rw-r--r--sysutils/vagrant/Makefile4
-rw-r--r--sysutils/vagrant/distinfo6
-rw-r--r--sysutils/vagrant/pkg-plist46
3 files changed, 52 insertions, 4 deletions
diff --git a/sysutils/vagrant/Makefile b/sysutils/vagrant/Makefile
index ea7d18311f47..156429db64da 100644
--- a/sysutils/vagrant/Makefile
+++ b/sysutils/vagrant/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vagrant
-PORTVERSION= 2.1.5
+PORTVERSION= 2.2.0
DISTVERSIONPREFIX= v
CATEGORIES= sysutils rubygems devel
@@ -27,6 +27,8 @@ RUN_DEPENDS= rubygem-bundler>=1.12.5:sysutils/rubygem-bundler \
rubygem-net-ssh>=5.0.0:security/rubygem-net-ssh \
rubygem-rb-kqueue>=0.2.0:devel/rubygem-rb-kqueue \
rubygem-rest-client>=1.6.0:www/rubygem-rest-client \
+ rubygem-rubyzip>=1.2.2:archivers/rubygem-rubyzip \
+ rubygem-vagrant_cloud>=2.0.1:sysutils/rubygem-vagrant_cloud \
rubygem-wdm>=0.1.0:devel/rubygem-wdm \
rubygem-winrm>=2.1:sysutils/rubygem-winrm \
rubygem-winrm-elevated>=1.1:sysutils/rubygem-winrm-elevated \
diff --git a/sysutils/vagrant/distinfo b/sysutils/vagrant/distinfo
index 41f23f42818c..bf23493a508c 100644
--- a/sysutils/vagrant/distinfo
+++ b/sysutils/vagrant/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536865463
-SHA256 (hashicorp-vagrant-v2.1.5_GH0.tar.gz) = 347179564f5a8a56e2d6dcb82470e04d92a60ed0b3265efc07f9ff37cd5c7f5f
-SIZE (hashicorp-vagrant-v2.1.5_GH0.tar.gz) = 1238788
+TIMESTAMP = 1540144506
+SHA256 (hashicorp-vagrant-v2.2.0_GH0.tar.gz) = cb1476683f0e8479334be20b26c49d516a0e1c739b9f6f35a8c05f68e4a048f1
+SIZE (hashicorp-vagrant-v2.2.0_GH0.tar.gz) = 1277421
diff --git a/sysutils/vagrant/pkg-plist b/sysutils/vagrant/pkg-plist
index 1e6b0c1307c0..a12b64b4adb8 100644
--- a/sysutils/vagrant/pkg-plist
+++ b/sysutils/vagrant/pkg-plist
@@ -128,6 +128,7 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/command_deprecation.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/counter.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/credential_scrubber.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/curl_helper.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/deep_merge.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/downloader.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/env.rb
@@ -157,6 +158,7 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/string_block_editor.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/subprocess.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/template_renderer.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/uploader.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/which.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/util/windows_path.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/lib/vagrant/vagrantfile.rb
@@ -174,6 +176,39 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/box/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cap/command.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cap/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/auth/login.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/auth/logout.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/auth/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/auth/root.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/auth/whoami.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/box/create.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/box/delete.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/box/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/box/root.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/box/show.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/box/update.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/client/client.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/errors.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/list.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/locales/en.yml
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/provider/create.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/provider/delete.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/provider/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/provider/root.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/provider/update.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/provider/upload.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/publish.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/root.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/search.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/util.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/version/create.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/version/delete.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/version/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/version/release.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/version/revoke.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/version/root.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/cloud/version/update.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/destroy/command.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/destroy/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/global-status/command.rb
@@ -258,10 +293,16 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/up/middleware/store_box_metadata.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/up/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/up/start_mixins.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/upload/command.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/upload/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/validate/command.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/validate/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/version/command.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/version/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/winrm/command.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/winrm/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/winrm_config/command.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/commands/winrm_config/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/communicators/ssh/communicator.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/communicators/ssh/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/communicators/winrm/command_filter.rb
@@ -304,6 +345,7 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/atomic/cap/docker.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/atomic/guest.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/atomic/plugin.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/bsd/cap/file_system.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/bsd/cap/halt.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/bsd/cap/nfs.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/bsd/cap/public_key.rb
@@ -369,6 +411,7 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/kali/guest.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/kali/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/linux/cap/choose_addressable_ip_addr.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/linux/cap/file_system.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/linux/cap/halt.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/linux/cap/mount_smb_shared_folder.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/linux/cap/mount_virtualbox_shared_folder.rb
@@ -440,6 +483,7 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/smartos/plugin.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/solaris/cap/change_host_name.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/solaris/cap/configure_networks.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/solaris/cap/file_system.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/solaris/cap/halt.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/solaris/cap/insert_public_key.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/solaris/cap/mount_virtualbox_shared_folder.rb
@@ -475,6 +519,7 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/windows/cap/change_host_name.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/windows/cap/choose_addressable_ip_addr.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/windows/cap/configure_networks.rb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/windows/cap/file_system.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/windows/cap/halt.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/windows/cap/mount_shared_folder.rb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/plugins/guests/windows/cap/public_key.rb
@@ -859,6 +904,7 @@ bin/vagrant
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/templates/commands/init/Vagrantfile.erb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/templates/commands/init/Vagrantfile.min.erb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/templates/commands/ssh_config/config.erb
+%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/templates/commands/winrm_config/config.erb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/templates/config/messages.erb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/templates/config/validation_failed.erb
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/templates/guests/alt/network_dhcp.erb