aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-curlftpfs/Makefile8
-rw-r--r--sysutils/fuser/Makefile3
-rw-r--r--sysutils/k8temp/Makefile8
3 files changed, 17 insertions, 2 deletions
diff --git a/sysutils/fusefs-curlftpfs/Makefile b/sysutils/fusefs-curlftpfs/Makefile
index 36126b14c564..956844bf27a1 100644
--- a/sysutils/fusefs-curlftpfs/Makefile
+++ b/sysutils/fusefs-curlftpfs/Makefile
@@ -24,4 +24,10 @@ USE_GNOME= glib20
MAN1= ${PORTNAME}.1
PLIST_FILES= bin/curlftpfs
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 900000
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fuser/Makefile b/sysutils/fuser/Makefile
index 27efa05e810a..58068ffaba60 100644
--- a/sysutils/fuser/Makefile
+++ b/sysutils/fuser/Makefile
@@ -34,6 +34,9 @@ EXTRA_PATCHES+= ${FILESDIR}/extra::patch-msdosfs.c
.if ${OSVERSION} >= 800101
EXTRA_PATCHES+= ${FILESDIR}/extra::patch-nfs.c
.endif
+.if ${OSVERSION} >= 900000
+BROKEN= does not build
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/sysutils/k8temp/Makefile b/sysutils/k8temp/Makefile
index 1dcb2e75e2a9..495002f572a4 100644
--- a/sysutils/k8temp/Makefile
+++ b/sysutils/k8temp/Makefile
@@ -23,4 +23,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/k8temp ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/k8temp.8 ${PREFIX}/man/man8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 900000
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>