aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/antiword/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/antiword/Makefile')
-rw-r--r--textproc/antiword/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/textproc/antiword/Makefile b/textproc/antiword/Makefile
index 2d095aa915f9..f1ab5bdb4473 100644
--- a/textproc/antiword/Makefile
+++ b/textproc/antiword/Makefile
@@ -17,17 +17,22 @@ USE_REINPLACE= yes
INSTALL_TARGET= global_install
MAN1= antiword.1
+PORTDOCS= COPYING ChangeLog Emacs Exmh FAQ History Mozilla Mutt Netscape \
+ QandA ReadMe antiword.1 antiword.man antiword.php testdoc.doc
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' \
-e 's,/usr/share,${PREFIX}/share,g' \
${WRKSRC}/Makefile.* ${WRKSRC}/*.[ch]
+ @${REINPLACE_CMD} -e 's,gcc,${CC},g' \
+ -e 's,-O2,${CFLAGS},g' \
+ ${WRKSRC}/${MAKEFILE} ${WRKSRC}/Makefile.*
post-install:
@${INSTALL_MAN} ${WRKSRC}/Docs/antiword.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/Docs/* ${DOCSDIR}
+ @cd ${WRKSRC}/Docs && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>