aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/coco/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/coco/Makefile')
-rw-r--r--textproc/coco/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/textproc/coco/Makefile b/textproc/coco/Makefile
index 017342ecf631..8064b2f6f5f9 100644
--- a/textproc/coco/Makefile
+++ b/textproc/coco/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.18 1995/04/23 10:33:33 asami Exp $
+# $Id: Makefile,v 1.19 1995/06/27 10:45:31 asami Exp $
#
DISTNAME= mule-2.2
@@ -25,7 +25,7 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
--terminal-face \
- --locallisppath=${PREFIX}/share/emacs/site-lisp:${PREFIX}/lib/mule/site-lisp
+ --locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
STRIP=
@@ -41,5 +41,8 @@ post-install:
gzip -9nf ${PREFIX}/man/man1/coco.1
gzip -9nf ${PREFIX}/man/man1/m2ps.1
gzip -9nf ${PREFIX}/man/man1/mule.1
+ if [ ! -d ${PREFIX}/share/emacs/site-lisp ]; then \
+ mkdir -p ${PREFIX}/share/emacs/site-lisp; \
+ fi
.include <bsd.port.mk>
umn1'>| | | | in the ports tree (via Mk/bsd.default-versions.mk and lang/gcc) which has now moved from GCC 6 to GCC 7 by default. This includes ports - featuring USE_GCC=yes or USE_GCC=any, - featuring USES=fortran, - using Mk/bsd.octave.mk which in turn features USES=fortran, and those - with USES=compiler specifying one of openmp, nestedfct, c11, c++0x, c++11-lib, c++11-lang, c++14-lang, c++17-lang, or gcc-c++11-lib. PR: 222542 * Mark as broken on aarch64, and, where appropriate, armvX.linimon2018-06-221-0/+2 | | | | | | While here, pet portlint. Approved by: portmgr (tier-2 blanket) * Use PY_FLAVOR for dependencies.mat2018-06-211-1/+1 | | | | | | | FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight * Bump PORTREVISIONs of all users of math/mpc that we just updated togerald2018-03-111-1/+1 | | | | version 1.1.0 (via revision 464079). * Reduce dependency on the python2 metaportantoine2018-02-191-2/+2 | | | | | PR: 225752 Submitted by: Yasuhiro KIMURA * Convert Python ports to FLAVORS.mat2017-11-301-1/+1 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2017-09-111-1/+1 | | | | | | | | | | | | | | (via Mk/bsd.default-versions.mk and lang/gcc) which has moved from GCC 5.4 to GCC 6.4 under most circumstances. This includes ports - with USE_GCC=yes or USE_GCC=any, - with USES=fortran, - using Mk/bsd.octave.mk which in turn features USES=fortran, and - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang, c++14-lang, c++0x, c11, or gcc-c++11-lib. PR: 219275 * - Fix shebangsamdmi32017-04-181-2/+4 | * Bump PORTREVISIONs for ports depending on the canonical version of GCC andgerald2017-04-011-1/+1 | | | | | | | | | | | | | | lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some circumstances such as versions of FreeBSD or platforms). This includes ports - with USE_GCC=yes or USE_GCC=any, - with USES=fortran, - using using Mk/bsd.octave.mk which in turn has USES=fortran, and - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang, c++11-lang, c++0x, c11, or gcc-c++11-lib. PR: 216707 * - Update devel/libpthread-stubs to 0.4ashish2017-03-29