aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libsass/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libsass/Makefile')
-rw-r--r--textproc/libsass/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/textproc/libsass/Makefile b/textproc/libsass/Makefile
index f1a1230277b3..f2c86ffbf1a2 100644
--- a/textproc/libsass/Makefile
+++ b/textproc/libsass/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= libsass
-PORTVERSION= 3.4.4
-PORTREVISION= 1
+PORTVERSION= 3.4.9
+PORTREVISION= 0
CATEGORIES= textproc
MAINTAINER= nivit@FreeBSD.org
@@ -12,17 +12,27 @@ COMMENT= C/C++ implementation of a Sass compiler
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GITHUB= yes
-GH_ACCOUNT= sass
+INSTALL_TARGET= install-strip
-USES= autoreconf compiler:c++11-lib gmake libtool pathfix
+GH_ACCOUNT= sass
GNU_CONFIGURE= yes
+
MAKEFILE= GNUmakefile
+
PATHFIX_MAKEFILEIN= GNUmakefile.am
-INSTALL_TARGET= install-strip
+STATIC_PIC= ${PORTNAME}_pic.a
+
+USES= autoreconf compiler:c++11-lib gmake libtool pathfix
+USE_GITHUB= yes
USE_LDCONFIG= yes
+post-build:
+ @(cd ${WRKSRC}/src/.libs && ${AR} rf ${STATIC_PIC} *.o)
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/.libs/${STATIC_PIC} ${STAGEDIR}${PREFIX}/lib
+
post-patch:
@${ECHO_CMD} "${ECHO_CMD} \"${PORTVERSION}\"" > ${WRKSRC}/version.sh
s'>+2 * Reset chinsan@FreeBSD.org due to numerous maintainer-timeouts and nolinimon2009-08-292-2/+2 * Reset maintainership, i do not use this port for a long time now.garga2009-08-271-1/+1 * - Update to 0.13miwi2009-08-273-9/+15 * Update to 190.25bland2009-08-272-4/+4 * Update to 190.25bland2009-08-272-4/+4 * On ia64, gdm (indirectly) uses log10 and ceil. Add libm to themarcel2009-08-251-0/+1 * xorg-server builds on ia64. Include it in the xorg meta-port.marcel2009-08-251-1/+1 * Pull galeon out of the Fifth Toe. It is no longer supported, and will bemarcus2009-08-251-2/+1 * - Add patch from upstream that fixes the HDD system monitor applet ifmarkus2009-08-234-2/+28 * - Reindent Makefile to fit in 80 columns, fix minor nitsdanfe2009-08-232-10/+8 * - Adjust port comment and descriptiondanfe2009-08-232-12/+11 * Chase the vte shared lib bump.marcus2009-08-237-6/+7 * Chase the fribidi shared lib bump.marcus2009-08-232-2/+2 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-2232-55/+35 * - Update to 20090815wxs2009-08-222-4/+4 * - Implement/Add the sensor 'system/uptime' for/to ksysguardd. As intendedmarkus2009-08-2112-0/+284 * Reset sbahra at his request due to lack of time to work on these ports.linimon2009-08-203-5/+5 * make startup notification really optionaloliver2009-08-16