aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Text-SpellChecker
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Text-SpellChecker')
-rw-r--r--textproc/p5-Text-SpellChecker/Makefile24
-rw-r--r--textproc/p5-Text-SpellChecker/distinfo3
-rw-r--r--textproc/p5-Text-SpellChecker/pkg-descr8
-rw-r--r--textproc/p5-Text-SpellChecker/pkg-plist6
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/p5-Text-SpellChecker/Makefile b/textproc/p5-Text-SpellChecker/Makefile
new file mode 100644
index 000000000000..fe8bc4348d47
--- /dev/null
+++ b/textproc/p5-Text-SpellChecker/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Text-SpellsChecker
+# Date created: 23 Nov 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-SpellChecker
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Perl5 OO interface for spell-checking a block of text
+
+RUN_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Text-Aspell>=0:${PORTSDIR}/textproc/p5-Text-Aspell
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::SpellChecker.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-SpellChecker/distinfo b/textproc/p5-Text-SpellChecker/distinfo
new file mode 100644
index 000000000000..48febb561bd5
--- /dev/null
+++ b/textproc/p5-Text-SpellChecker/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-SpellChecker-0.03.tar.gz) = 280994c1d9dc2583964f7c882b9e0943
+SHA256 (Text-SpellChecker-0.03.tar.gz) = 9c093ccef820e64c8abf11ee142561d477c962fa730ac77f5c8f9c6da4fa6d4c
+SIZE (Text-SpellChecker-0.03.tar.gz) = 3632
diff --git a/textproc/p5-Text-SpellChecker/pkg-descr b/textproc/p5-Text-SpellChecker/pkg-descr
new file mode 100644
index 000000000000..afad95739360
--- /dev/null
+++ b/textproc/p5-Text-SpellChecker/pkg-descr
@@ -0,0 +1,8 @@
+This module is built on Text::Aspell, but adds some of the
+functionality provided by the internal gnu aspell API. This allows
+one to deal with blocks of text, rather than just words. For
+instance, we provide methods for iterating through the text,
+serializing the object (thus remembering where we left off), and
+highlighting the current misspelled word within the text.
+
+WWW: http://search.cpan.org/dist/Text-SpellChecker/
diff --git a/textproc/p5-Text-SpellChecker/pkg-plist b/textproc/p5-Text-SpellChecker/pkg-plist
new file mode 100644
index 000000000000..0a2bc53b85a0
--- /dev/null
+++ b/textproc/p5-Text-SpellChecker/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Text/SpellChecker.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/SpellChecker/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/SpellChecker
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/Text