aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-Reader/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-Reader/Makefile')
-rw-r--r--textproc/p5-XML-Reader/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/textproc/p5-XML-Reader/Makefile b/textproc/p5-XML-Reader/Makefile
index 9a3ebdbd9f31..1913cc53ce36 100644
--- a/textproc/p5-XML-Reader/Makefile
+++ b/textproc/p5-XML-Reader/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= XML-Reader
-PORTVERSION= 0.64
+PORTVERSION= 0.65
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,10 +12,10 @@ COMMENT= Reading XML and providing path information based on a pull-parser
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-Net-HTTP>=0:${PORTSDIR}/net/p5-Net-HTTP
-BUILD_DEPENDS= ${RUN_DEPENDS}
-TEST_DEPENDS= p5-XML-Parser>=1:${PORTSDIR}/textproc/p5-XML-Parser \
- p5-XML-Parsepp>=0.04:${PORTSDIR}/textproc/p5-XML-Parsepp
+BUILD_DEPENDS= p5-Acme-HTTP>=0:${PORTSDIR}/net/p5-Acme-HTTP
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-Parsepp>=0:${PORTSDIR}/textproc/p5-XML-Parsepp
USES= perl5
USE_PERL5= configure
@@ -23,12 +23,7 @@ USE_PERL5= configure
OPTIONS_DEFINE= PP
PP_DESC= Use XML::Parsepp
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPP}
-RUN_DEPENDS+= p5-XML-Parsepp>=0.04:${PORTSDIR}/textproc/p5-XML-Parsepp
-.else
-RUN_DEPENDS+= p5-XML-Parser>=1:${PORTSDIR}/textproc/p5-XML-Parser
-.endif
+PP_RUN_DEPENDS= p5-XML-Parsepp>=0:${PORTSDIR}/textproc/p5-XML-Parsepp
+PP_RUN_DEPENDS_OFF= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
.include <bsd.port.mk>