aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-fingerprints/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-fingerprints/Makefile')
-rw-r--r--textproc/py-fingerprints/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/py-fingerprints/Makefile b/textproc/py-fingerprints/Makefile
new file mode 100644
index 000000000000..4506658b6f94
--- /dev/null
+++ b/textproc/py-fingerprints/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= fingerprints
+DISTVERSION= 0.5.4
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Easy comparing and cross-referencing of companies and people
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}normality>=0.4.0:textproc/py-normality@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+post-extract:
+ # Prevents that the tests directory will be installed into site-packages
+ @(cd ${WRKSRC} && ${MV} tests test)
+
+.include <bsd.port.mk>