aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/scew
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/scew')
-rw-r--r--textproc/scew/Makefile38
-rw-r--r--textproc/scew/distinfo5
-rw-r--r--textproc/scew/pkg-descr17
-rw-r--r--textproc/scew/pkg-plist10
4 files changed, 38 insertions, 32 deletions
diff --git a/textproc/scew/Makefile b/textproc/scew/Makefile
index d7d7fd1bcd15..ade86c171e82 100644
--- a/textproc/scew/Makefile
+++ b/textproc/scew/Makefile
@@ -2,39 +2,35 @@
# $FreeBSD$
PORTNAME= scew
-PORTVERSION= 1.1.7
-PORTREVISION= 3
+PORTVERSION= 1.1.9
CATEGORIES= textproc
-MASTER_SITES= SAVANNAH/${PORTNAME}/
+MASTER_SITES= SAVANNAH
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Simple C Expat Wrapper
LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2
-USES= gmake libtool pathfix pkgconfig
+OPTIONS_DEFINE= TEST
+.if defined(MAINTAINER_MODE)
+OPTIONS_DEFAULT=TEST
+.endif
+
+USES= gmake libtool localbase pathfix pkgconfig
+CONFIGURE_ARGS= enable_tests=yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-SCEW_EXAMPLES= print stream write
+TEST_LIB_DEPENDS= libcheck.so:devel/check
+TEST_VARS= TEST_TARGET=check TEST_WRKSRC=${WRKSRC}/tests
post-install:
-.for ex in ${SCEW_EXAMPLES}
- ${INSTALL_SCRIPT} \
- ${WRKSRC}/examples/${PORTNAME}_${ex}/${PORTNAME}_${ex} \
- ${STAGEDIR}${PREFIX}/bin
-.endfor
-
-.ifdef MAINTAINER_MODE
-LIB_DEPENDS+= libcheck.so:devel/check
-regression-test: build
- ${MAKE_CMD} -C ${WRKSRC}/tests check
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/scew_print/scew_print ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/scew_stream/scew_stream ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/scew_write/scew_write ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/textproc/scew/distinfo b/textproc/scew/distinfo
index d26b2fee1f96..9500959abf40 100644
--- a/textproc/scew/distinfo
+++ b/textproc/scew/distinfo
@@ -1,2 +1,3 @@
-SHA256 (scew-1.1.7.tar.gz) = 2b7b4d69723e1a6d550bbc294e68673d1c7c0d9825ce8a51415c46a565109a50
-SIZE (scew-1.1.7.tar.gz) = 475151
+TIMESTAMP = 1518875974
+SHA256 (scew-1.1.9.tar.gz) = 10009a9b5a4b72469bccbd8ad2e69a4287031f13e56747ee282ce46a19a12579
+SIZE (scew-1.1.9.tar.gz) = 506371
diff --git a/textproc/scew/pkg-descr b/textproc/scew/pkg-descr
index 0940e616707c..6e268af31e78 100644
--- a/textproc/scew/pkg-descr
+++ b/textproc/scew/pkg-descr
@@ -1,5 +1,14 @@
-The aim of SCEW is to provide an easy interface around the Expat XML parser.
-SCEW also incorporates functions to create and handle XML trees. That is, add
-and delete nodes, change attribute names and values, etc.
+The aim of SCEW is to provide an easy interface around the XML Expat parser, as
+well as a simple interface for creating new XML documents. It provides functions
+to load and access XML elements without the need to create Expat event handling
+routines every time you want to load a new XML document.
-WWW: http://www.nongnu.org/scew/
+These are the main SCEW features:
+- Uses a DOM-like object model for new or parsed XML documents.
+- Supports loading concatenated XML documents.
+- Can copy and compare full XML documents, elements or attributes.
+- Writes XML documents to multiple outputs.
+- Allows adding new I/O sources easily.
+- UTF-8, ISO-8859-1 and US-ASCII encodings (and UTF-16 in Windows).
+
+WWW: https://savannah.nongnu.org/projects/scew
diff --git a/textproc/scew/pkg-plist b/textproc/scew/pkg-plist
index 01ff332628f6..54b6f4abd13b 100644
--- a/textproc/scew/pkg-plist
+++ b/textproc/scew/pkg-plist
@@ -1,11 +1,6 @@
bin/scew_print
bin/scew_stream
bin/scew_write
-libdata/pkgconfig/scew.pc
-lib/libscew.a
-lib/libscew.so
-lib/libscew.so.1
-lib/libscew.so.1.0.8
include/scew/attribute.h
include/scew/bool.h
include/scew/element.h
@@ -23,3 +18,8 @@ include/scew/tree.h
include/scew/writer.h
include/scew/writer_buffer.h
include/scew/writer_file.h
+lib/libscew.a
+lib/libscew.so
+lib/libscew.so.1
+lib/libscew.so.1.0.10
+libdata/pkgconfig/scew.pc