aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/scrollkeeper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/scrollkeeper/Makefile')
-rw-r--r--textproc/scrollkeeper/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/scrollkeeper/Makefile b/textproc/scrollkeeper/Makefile
new file mode 100644
index 000000000000..1ce32cca1be5
--- /dev/null
+++ b/textproc/scrollkeeper/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: scrollkeeper
+# Date created: 6 April 2001
+# Whom: Rene Hexel <rh@netbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scrollkeeper
+PORTVERSION= 0.2
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ${MASTER_SITE_GNOME:S,%SUBDIR%,stable/sources/scrollkeeper,}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml \
+ intl.1:${PORTSDIR}/devel/gettext
+
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=/var
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lintl"
+
+MAN8= scrollkeeper-config.8 scrollkeeper-preinstall.8 \
+ scrollkeeper-rebuilddb.8 scrollkeeper-update.8
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$$\(LN_S\) -f -n|\$$\(LN_S\) -f|g'
+
+.include <bsd.port.mk>