aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/sift/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/sift/Makefile')
-rw-r--r--textproc/sift/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/sift/Makefile b/textproc/sift/Makefile
new file mode 100644
index 000000000000..5b74066261e5
--- /dev/null
+++ b/textproc/sift/Makefile
@@ -0,0 +1,31 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sift
+PORTVERSION= 0.9.0
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast and powerful open source alternative to grep
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+PLIST_FILES= bin/sift
+
+GH_ACCOUNT= svent
+GH_TUPLE= golang:crypto:3d3f9f4:golang_crypto/../src/golang.org/x/crypto \
+ golang:sys:62eef0e:golang_sys/../src/golang.org/x/sys \
+ svent:go-flags:4bcbad3:svent_goflags/../src/github.com/svent/go-flags \
+ svent:go-nbreader:7cef48d:svent_gonbreader/../src/github.com/svent/go-nbreader
+USE_GITHUB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/sift ${STAGEDIR}${PREFIX}/bin/sift
+
+.include <bsd.port.mk>