aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/the_silver_searcher/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/the_silver_searcher/Makefile')
-rw-r--r--textproc/the_silver_searcher/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/textproc/the_silver_searcher/Makefile b/textproc/the_silver_searcher/Makefile
new file mode 100644
index 000000000000..2c1414f62a5a
--- /dev/null
+++ b/textproc/the_silver_searcher/Makefile
@@ -0,0 +1,23 @@
+# Created by: Gea-Suan Lin <gslin@gslin.org>
+# $FreeBSD$
+
+PORTNAME= the_silver_searcher
+PORTVERSION= 0.12
+CATEGORIES= textproc
+MASTER_SITES= http://cloud.github.com/downloads/ggreer/${PORTNAME}/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A code-searching tool similar to ack but faster
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+ACLOCAL_ARGS+= -I ${ACLOCAL_DIR}
+AUTOMAKE_ARGS+= --add-missing
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/ag
+USE_AUTOTOOLS= aclocal autoconf autoheader automake
+USE_PKGCONFIG= build
+
+MAN1= ag.1
+
+.include <bsd.port.mk>