aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/muse/Makefile2
-rw-r--r--textproc/muse/files/patch-Makefile13
-rw-r--r--textproc/muse/pkg-plist2
3 files changed, 15 insertions, 2 deletions
diff --git a/textproc/muse/Makefile b/textproc/muse/Makefile
index c912d2ba978e..8eb3922f9874 100644
--- a/textproc/muse/Makefile
+++ b/textproc/muse/Makefile
@@ -19,6 +19,8 @@ USE_EMACS= yes
USE_GMAKE= yes
EMACS_PORT_NAME?= emacs21
+INFO= muse
+
.if ${EMACS_PORT_NAME} != "emacs21"
PORTNAMESUFFIX= ${PKGNAMESUFFIX}
.endif
diff --git a/textproc/muse/files/patch-Makefile b/textproc/muse/files/patch-Makefile
new file mode 100644
index 000000000000..23d453d732ea
--- /dev/null
+++ b/textproc/muse/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Sat Sep 9 12:17:41 2006
++++ Makefile Sat Sep 9 12:17:51 2006
+@@ -43,8 +43,8 @@
+
+ install-info: $(MANUAL).info
+ [ -d $(INFODIR) ] || install -d $(INFODIR)
+- install -m 0644 $(MANUAL).info $(INFODIR)/$(MANUAL)
+- $(INSTALLINFO) $(INFODIR)/$(MANUAL)
++ install -m 0644 $(MANUAL).info $(INFODIR)/$(MANUAL).info
++ $(INSTALLINFO) $(INFODIR)/$(MANUAL).info
+
+ install-bin: autoloads lisp contrib
+ (cd lisp && $(MAKE) install)
diff --git a/textproc/muse/pkg-plist b/textproc/muse/pkg-plist
index 550d7fbf720e..0ee8ed14cf6c 100644
--- a/textproc/muse/pkg-plist
+++ b/textproc/muse/pkg-plist
@@ -1,5 +1,3 @@
-info/muse
-@unexec install-info --quiet --delete %D/info/muse %D/info/dir
%%EMACS_SITE_LISPDIR%%/muse/contrib/cgi.el
%%EMACS_SITE_LISPDIR%%/muse/contrib/cgi.elc
%%EMACS_SITE_LISPDIR%%/muse/contrib/httpd.el