aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-RDF-Simple/Makefile20
-rw-r--r--textproc/p5-RDF-Simple/distinfo6
-rw-r--r--textproc/p5-RDF-Simple/pkg-descr1
3 files changed, 14 insertions, 13 deletions
diff --git a/textproc/p5-RDF-Simple/Makefile b/textproc/p5-RDF-Simple/Makefile
index 27753f461e24..3c0b6369ae00 100644
--- a/textproc/p5-RDF-Simple/Makefile
+++ b/textproc/p5-RDF-Simple/Makefile
@@ -6,32 +6,32 @@
#
PORTNAME= RDF-Simple
-PORTVERSION= 0.13
-PORTREVISION= 1
+PORTVERSION= 0.30
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= RDF
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-0.3
MAINTAINER= ascope@cpan.org
COMMENT= Read and write RDF without complication
BUILD_DEPENDS= ${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
- ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
- ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= RDF::Simple.3 RDF::Simple::Parser.3 RDF::Simple::Serialiser.3
+MAN3= RDF::Simple.3 \
+ RDF::Simple::NS.3 \
+ RDF::Simple::Parser.3 \
+ RDF::Simple::Serialiser.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-post-patch:
- @${PERL} -pi -e 's/^our (\S+)/use vars q{$$1};$$1/g' \
- ${WRKSRC}/lib/RDF/Simple.pm ${WRKSRC}/lib/RDF/Simple/*.pm
+.if ${PERL_LEVEL} < 500600 #inherited from security/p5-Authen-SASL
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/p5-RDF-Simple/distinfo b/textproc/p5-RDF-Simple/distinfo
index 9c92c1a98789..35c4c71a8dba 100644
--- a/textproc/p5-RDF-Simple/distinfo
+++ b/textproc/p5-RDF-Simple/distinfo
@@ -1,3 +1,3 @@
-MD5 (RDF-Simple-0.13.tar.gz) = f8de39dee049070b94e05ddeb45ba34b
-SHA256 (RDF-Simple-0.13.tar.gz) = 8aad30e6a9ca9c6a1be440a6b59020cce1752ad44609852da8cca0c29448427e
-SIZE (RDF-Simple-0.13.tar.gz) = 16835
+MD5 (RDF-Simple-0.3.tar.gz) = e49933a243a323a4b4f5867d5c0a25aa
+SHA256 (RDF-Simple-0.3.tar.gz) = 9f790ff225ed6168001881119bda1b8c5e50bd6bdc62384765d2fdf7698b2e1c
+SIZE (RDF-Simple-0.3.tar.gz) = 17985
diff --git a/textproc/p5-RDF-Simple/pkg-descr b/textproc/p5-RDF-Simple/pkg-descr
index 03fbac37dfd7..1acbde67550d 100644
--- a/textproc/p5-RDF-Simple/pkg-descr
+++ b/textproc/p5-RDF-Simple/pkg-descr
@@ -2,3 +2,4 @@ RDF::Simple is for very simple manipulations of RDF/XML serialisations
of RDF graphs.
WWW: http://search.cpan.org/dist/RDF-Simple/
+Author: Jo Walsh <jo@london.pm.org>