aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium/files/patch-build__common.gypi
diff options
context:
space:
mode:
Diffstat (limited to 'www/chromium/files/patch-build__common.gypi')
-rw-r--r--www/chromium/files/patch-build__common.gypi29
1 files changed, 14 insertions, 15 deletions
diff --git a/www/chromium/files/patch-build__common.gypi b/www/chromium/files/patch-build__common.gypi
index 1f43a64d8a63..992009dc1b0b 100644
--- a/www/chromium/files/patch-build__common.gypi
+++ b/www/chromium/files/patch-build__common.gypi
@@ -1,6 +1,6 @@
---- ./build/common.gypi.orig 2014-04-24 22:36:09.000000000 +0200
-+++ ./build/common.gypi 2014-04-24 23:23:42.000000000 +0200
-@@ -565,7 +565,7 @@
+--- ./build/common.gypi.orig 2014-04-30 22:43:21.000000000 +0200
++++ ./build/common.gypi 2014-05-04 14:43:03.000000000 +0200
+@@ -615,7 +615,7 @@
}],
# DBus usage.
@@ -9,27 +9,26 @@
'use_dbus%': 1,
}, {
'use_dbus%': 0,
-@@ -1002,6 +1002,10 @@
+@@ -878,7 +878,7 @@
+ # By default, use ICU data file (icudtl.dat) on all platforms
+ # except when building Android WebView.
+ # TODO(jshin): Handle 'use_system_icu' on Linux (Chromium).
+- ['android_webview_build==0', {
++ ['android_webview_build==0 and OS!="freebsd" and OS!="openbsd"', {
+ 'icu_use_data_file_flag%' : 1,
+ }, {
+ 'icu_use_data_file_flag%' : 0,
+@@ -1076,6 +1076,9 @@
# able to turn it off for various reasons.
'linux_disable_pie%': 0,
+ 'os_ver%': 0,
-+ 'prefix_dir%': '/usr',
+ 'use_system_libjpeg%': 0,
+
# The release channel that this build targets. This is used to restrict
# channel-specific build options, like which installer packages to create.
# The default is 'all', which does no channel-specific filtering.
-@@ -1322,7 +1326,7 @@
- # TODO(jungshik): Turn this on on Android.
- # For ChromeOS, this should be turned on in chromeos-chrome.ebuild
- # file as well by adding icu_use_data_file_flag=1 to BUILD_DEFINES.
-- ['OS!="android"', {
-+ ['OS!="android" and os_bsd!=1', {
- 'icu_use_data_file_flag%': 1,
- }],
- ],
-@@ -3701,6 +3705,13 @@
+@@ -3894,6 +3897,13 @@
'ldflags': [
'-Wl,--no-keep-memory',
],