aboutsummaryrefslogtreecommitdiffstats
path: root/www/dojo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/dojo/Makefile')
-rw-r--r--www/dojo/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/www/dojo/Makefile b/www/dojo/Makefile
index 2142e1d4580e..1ee9f6c01874 100644
--- a/www/dojo/Makefile
+++ b/www/dojo/Makefile
@@ -14,29 +14,29 @@ SHAREOWN= www
SHAREGRP= www
OPTIONS_DEFINE= APACHE
+OPTIONS_SUB= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22+
CONFDIR= ${PREFIX}/${CONFDIR_REL}
CONFDIR_REL= ${APACHEETCDIR}/Includes
-PLIST_SUB+= NOAPACHE="" CONFDIR=${CONFDIR_REL}
+PLIST_SUB+= CONFDIR=${CONFDIR_REL}
CONF= dojo.conf
SUB_FILES+= pkg-message ${CONF}
-.else
-PLIST_SUB+= NOAPACHE="@comment "
.endif
do-install:
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
.if ${PORT_OPTIONS:MAPACHE}
-post-install:
- @if [ -d "${CONFDIR}" ]; then \
- ${CP} ${WRKDIR}/${CONF} ${CONFDIR}/dojo.conf; \
+. if empty(STAGEDIR)
+ @${MKDIR} ${STAGEDIR}${CONFDIR}
+. endif
+ @if [ -d "${STAGEDIR}${CONFDIR}" ]; then \
+ ${CP} ${WRKDIR}/${CONF} ${STAGEDIR}${CONFDIR}/dojo.conf; \
else \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please check your Apache 2.x installation -" ; \
@@ -45,7 +45,6 @@ post-install:
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
- @${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.mk>