aboutsummaryrefslogtreecommitdiffstats
path: root/www/domoticz/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/domoticz/Makefile')
-rw-r--r--www/domoticz/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/www/domoticz/Makefile b/www/domoticz/Makefile
index 06f5e33ff1d6..8341d2693a87 100644
--- a/www/domoticz/Makefile
+++ b/www/domoticz/Makefile
@@ -2,12 +2,8 @@
PORTNAME= domoticz
PORTVERSION= 4.${DOMOTICZ_REL}
-PORTREVISION= 6
CATEGORIES= www
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= 9d226dab339f.patch:-p1
-
MAINTAINER= kiwi@oav.net
COMMENT= Home Automation System
@@ -36,11 +32,9 @@ USES= cmake compiler:c++11-lang iconv pkgconfig ssl
# This hack is to get rid of dependency of git while building
# the package.
-DOMOTICZ_REL= 9700
-DOMOTICZ_TS= 1529904511
+DOMOTICZ_REL= 10717
+DOMOTICZ_TS= 1565707487
USE_GITHUB= yes
-GH_ACCOUNT= domoticz
-GH_PROJECT= domoticz
USE_RC_SUBR= domoticz
@@ -95,7 +89,7 @@ LIB_DEPENDS+= libminizip.so:archivers/minizip
.if ${PORT_OPTIONS:MPYTHON}
CMAKE_ARGS+= -DUSE_PYTHON="YES"
-USES+= python:3.4
+USES+= python:3.6
.else
CMAKE_ARGS+= -DUSE_PYTHON="NO"
.endif
@@ -109,7 +103,7 @@ post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e "/^ADD_PRECOMPILED_HEADER/ d" ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e "s/\(#define APPVERSION\)\(.*\)/\1 ${DOMOTICZ_REL}/" ${WRKSRC}/appversion.default
- @${REINPLACE_CMD} -e "s/\(#define APPHASH\)\(.*\)/\1 \"27772d9f\"/" ${WRKSRC}/appversion.default
+ @${REINPLACE_CMD} -e "s/\(#define APPHASH\)\(.*\)/\1 \"be79a17\"/" ${WRKSRC}/appversion.default
@${REINPLACE_CMD} -e "s/\(#define APPDATE\)\(.*\)/\1 ${DOMOTICZ_TS}/" ${WRKSRC}/appversion.default
post-install: