aboutsummaryrefslogtreecommitdiffstats
path: root/www/epiphany-extensions/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/epiphany-extensions/Makefile')
-rw-r--r--www/epiphany-extensions/Makefile47
1 files changed, 31 insertions, 16 deletions
diff --git a/www/epiphany-extensions/Makefile b/www/epiphany-extensions/Makefile
index abdaa5f52ff2..3ba13f9b6044 100644
--- a/www/epiphany-extensions/Makefile
+++ b/www/epiphany-extensions/Makefile
@@ -3,15 +3,15 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/epiphany-extensions/Makefile,v 1.54 2005/10/02 23:33:10 marcus Exp $
+# $MCom: ports/www/epiphany-extensions/Makefile,v 1.72 2006/04/24 04:49:23 marcus Exp $
#
PORTNAME= epiphany
-PORTVERSION= 1.8.2
-PORTREVISION= 2
+PORTVERSION= 2.14.1
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}${PKGNAMESUFFIX}/1.8
+MASTER_SITE_SUBDIR= sources/${PORTNAME}${PKGNAMESUFFIX}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PKGNAMESUFFIX= -extensions
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -22,30 +22,27 @@ COMMENT= A set of add-ons for the Epiphany web browser
BUILD_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
+USE_GETTEXT= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GECKO= firefox mozilla seamonkey
USE_GNOME= gnomeprefix gnomehack intlhack gnometarget
+INSTALLS_OMF= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --with-extensions="all" \
- --with-mozilla=${GECKO}
+CONFIGURE_ARGS= --with-mozilla=${GECKO}
-PLIST_SUB= VERSION="1.8" EPHY_VERSION="1.8"
+EPHY_EXTENSIONS=all
-.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
-.undef WITHOUT_OPENSP
-WITH_OPENSP= yes
-.endif
+PLIST_SUB= VERSION="2.14" EPHY_VERSION="2.14"
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+OPTIONS= OPENSP "Enable OpenSP SGML support" off \
+ ADBLOCK "Enable the adblock extension" on
-.if exists(${LOCALBASE}/lib/libosp.so)
-WITH_OPENSP= yes
-.endif
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if defined(WITH_OPENSP)
CONFIGURE_ARGS+= --enable-opensp=yes
@@ -53,6 +50,24 @@ CONFIGURE_ARGS+= --enable-opensp=yes
CONFIGURE_ARGS+= --disable-opensp
.endif
+.if !defined(WITHOUT_ADBLOCK)
+EPHY_EXTENSIONS:= ${EPHY_EXTENSIONS},adblock
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre-utf8
+PLIST_SUB+= ADBLOCK=""
+.else
+PLIST_SUB+= ADBLOCK="@comment "
+.endif
+
+.if exists(${LOCALBASE}/share/pygtk/2.0/defs/epiphany.defs)
+USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+PLIST_SUB+= PYTHON=""
+.else
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+CONFIGURE_ARGS+=--with-extensions="${EPHY_EXTENSIONS}"
+
pre-everything::
@${ECHO_MSG} "Epiphany-extensions also supports the following tunable option(s):"
@${ECHO_MSG} " WITH_OPENSP=yes Enable support for OpenSP SGML validation"