aboutsummaryrefslogtreecommitdiffstats
path: root/www/flat-frog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/flat-frog/Makefile')
-rw-r--r--www/flat-frog/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/www/flat-frog/Makefile b/www/flat-frog/Makefile
index b3c334ddeff5..7055bbde5fc4 100644
--- a/www/flat-frog/Makefile
+++ b/www/flat-frog/Makefile
@@ -13,17 +13,14 @@ NO_BUILD= yes
USE_PHP= yes
USES= zip
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR} ${DATADIR}/plugins
- ${INSTALL_DATA} ${WRKSRC}/src/class.* ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/src/plugins/* ${DATADIR}/plugins
- ${MKDIR} ${EXAMPLESDIR} ${EXAMPLESDIR}/templates
- ${INSTALL_DATA} ${WRKSRC}/demo/test.* ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/demo/templates/* ${EXAMPLESDIR}/templates
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${DATADIR}/plugins
+ ${INSTALL_DATA} ${WRKSRC}/src/class.* ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/plugins/* ${STAGEDIR}${DATADIR}/plugins
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR} ${STAGEDIR}${EXAMPLESDIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/demo/test.* ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/demo/templates/* ${STAGEDIR}${EXAMPLESDIR}/templates
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>