aboutsummaryrefslogtreecommitdiffstats
path: root/www/gitea/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/gitea/Makefile')
-rw-r--r--www/gitea/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/www/gitea/Makefile b/www/gitea/Makefile
index d8d6a06e4a5c..7fb569c13380 100644
--- a/www/gitea/Makefile
+++ b/www/gitea/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gitea
DISTVERSIONPREFIX= v
DISTVERSION= 1.9.3
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= stb@lassitu.de
@@ -19,7 +20,7 @@ USE_GITHUB= yes
GH_ACCOUNT= go-gitea
USE_RC_SUBR= gitea
-GO_BUILDFLAGS= -tags "${GO_TAGS}"
+GO_BUILDFLAGS= -tags "${GO_TAGS}" -ldflags '-X "main.Version=${PORTVERSION}"'
SUB_FILES+= app.ini.sample
SUB_LIST+= GITUSER=${USERS}
@@ -47,15 +48,6 @@ DAEMONARGS= -f
SUB_LIST+= DAEMONARGS="${DAEMONARGS}"
-post-patch:
- # Gitea releases don't supply the release version number; the
- # automatic method to obtain the version number in the Gitea build
- # system only works when sources are checked out from git.
- # See https://github.com/go-gitea/gitea/issues/1136#issuecomment-311622745
- @${SED} -Ei .orig \
- -e 's#^(var Version = )"[^"]+"#\1"${PORTVERSION}"#' \
- ${GO_WRKSRC}/main.go
-
do-install:
${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
@${MKDIR} ${STAGEDIR}${ETCDIR}/conf