aboutsummaryrefslogtreecommitdiffstats
path: root/www/hs-snap-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-snap-server/Makefile')
-rw-r--r--www/hs-snap-server/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/www/hs-snap-server/Makefile b/www/hs-snap-server/Makefile
index 80d313bec2a5..ec06ccccd913 100644
--- a/www/hs-snap-server/Makefile
+++ b/www/hs-snap-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= snap-server
-PORTVERSION= 0.8.1.1
+PORTVERSION= 0.9.0
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -20,24 +20,25 @@ USE_CABAL= attoparsec>=0.10 attoparsec-enumerator>=0.3 \
blaze-builder>=0.2.1.4 blaze-builder-enumerator>=0.2.0 \
bytestring-nums case-insensitive>=0.3 directory-tree>=0.10 \
enumerator>=0.4.15 MonadCatchIO-transformers>=0.2.1 \
- mtl>=2 murmur-hash>=0.1 network>=2.3 PSQueue>=1.1 \
- snap-core>=0.8.1 text>=0.11 transformers>=0.2 unix-compat>=0.2 \
- vector>=0.7 vector-algorithms>=0.4
+ mtl>=2 murmur-hash>=0.1 network>=2.3 snap-core>=0.9 \
+ text>=0.11 transformers>=0.2 unix-compat>=0.2 vector>=0.7 \
+ vector-algorithms>=0.4
-OPTIONS= LIBEV "Use libev" off \
- OPENSSL "Enable HTTPS support using the HsOpenSSL library" off
+OPTIONS_DEFINE= LIBEV OPENSSL
+
+LIBEV_DESC= Use libev
+OPENSSL_DESC= Enable HTTPS support using the HsOpenSSL library
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_LIBEV)
+.if ${PORT_OPTIONS:MLIBEV}
CONFIGURE_ARGS+= --flags="libev"
USE_CABAL+= hlibev
.else
CONFIGURE_ARGS+= --flags="-libev"
.endif
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+= --flags="openssl"
USE_CABAL+= HsOpenSSL
.else