aboutsummaryrefslogtreecommitdiffstats
path: root/www/hs-warp-tls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-warp-tls/Makefile')
-rw-r--r--www/hs-warp-tls/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/www/hs-warp-tls/Makefile b/www/hs-warp-tls/Makefile
new file mode 100644
index 000000000000..4cb31ad4d14e
--- /dev/null
+++ b/www/hs-warp-tls/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= warp-tls
+PORTVERSION= 3.0.0
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= HTTP over SSL/TLS support for Warp via the TLS package
+
+LICENSE= MIT
+
+USE_CABAL= cprng-aes>=0.5.0 data-default-class>=0.0.1 network>=2.2.1 \
+ streaming-commons tls>=1.2.1 wai>=3.0 warp>=3.0
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>