aboutsummaryrefslogtreecommitdiffstats
path: root/www/lua-resty-lrucache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/lua-resty-lrucache/Makefile')
-rw-r--r--www/lua-resty-lrucache/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/lua-resty-lrucache/Makefile b/www/lua-resty-lrucache/Makefile
new file mode 100644
index 000000000000..c6c640599512
--- /dev/null
+++ b/www/lua-resty-lrucache/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= lua-resty-lrucache
+PORTVERSION= 0.09
+DISTVERSIONPREFIX=v
+CATEGORIES= www
+
+MAINTAINER= dmitry.wagin@ya.ru
+COMMENT= Lua-land LRU cache based on the LuaJIT FFI
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= luajit-openresty>=2.1:lang/luajit-openresty
+
+USE_GITHUB= yes
+GH_ACCOUNT= openresty
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+LUA_MODSHAREDIR=${LOCALBASE}/share/lua/5.1
+
+PLIST_FILES+= ${LUA_MODSHAREDIR}/resty/lrucache.lua \
+ ${LUA_MODSHAREDIR}/resty/lrucache/pureffi.lua
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${LUA_MODSHAREDIR}
+ @(cd ${WRKSRC}/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${LUA_MODSHAREDIR} "-name *\.lua")
+
+.include <bsd.port.mk>