aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_auth_openidc
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_auth_openidc')
-rw-r--r--www/mod_auth_openidc/Makefile54
-rw-r--r--www/mod_auth_openidc/distinfo3
-rw-r--r--www/mod_auth_openidc/files/pkg-message.in7
-rw-r--r--www/mod_auth_openidc/pkg-descr7
-rw-r--r--www/mod_auth_openidc/pkg-plist1
5 files changed, 72 insertions, 0 deletions
diff --git a/www/mod_auth_openidc/Makefile b/www/mod_auth_openidc/Makefile
new file mode 100644
index 000000000000..c48997c00723
--- /dev/null
+++ b/www/mod_auth_openidc/Makefile
@@ -0,0 +1,54 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mod_auth_openidc
+PORTVERSION= 2.3.1
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= OpenID Connect Relying Party and OAuth 2.0 Resource Server for Apache
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libcjose.so:devel/cjose \
+ libcurl.so:ftp/curl \
+ libjansson.so:devel/jansson \
+ libpcre.so:devel/pcre
+
+USES= autoreconf:autoconf cpe gmake libtool pkgconfig ssl
+USE_APACHE= 22+
+USE_GITHUB= yes
+GH_ACCOUNT= pingidentity
+CPE_VENDOR= ${GH_ACCOUNT}
+
+PLIST_FILES= ${APACHEMODDIR}/mod_auth_openidc.so
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto" \
+ PKG_CONFIG_PATH="${LOCALBASE}/libdata/pkgconfig"
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= HIREDIS
+HIREDIS_DESC= Enable using redis to store session data
+HIREDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
+HIREDIS_CONFIGURE_WITH= hiredis
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|@APXS2@ @APXS2_OPTS@ -i|@APXS2@ @APXS2_OPTS@ -S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR} -i|' \
+ ${WRKSRC}/Makefile.in
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR} \
+ ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/Includes
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${PORTNAME}.so
+ ${INSTALL_DATA} ${WRKSRC}/auth_openidc.conf \
+ ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/Includes/auth_openidc.conf.sample
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_openidc/distinfo b/www/mod_auth_openidc/distinfo
new file mode 100644
index 000000000000..5008c690a81e
--- /dev/null
+++ b/www/mod_auth_openidc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1505264187
+SHA256 (pingidentity-mod_auth_openidc-v2.3.1_GH0.tar.gz) = 4bbed6531b24bfcfd3e2e10911831216a68246a00908a226a97812f9fc9cd337
+SIZE (pingidentity-mod_auth_openidc-v2.3.1_GH0.tar.gz) = 210766
diff --git a/www/mod_auth_openidc/files/pkg-message.in b/www/mod_auth_openidc/files/pkg-message.in
new file mode 100644
index 000000000000..17b27c4c3282
--- /dev/null
+++ b/www/mod_auth_openidc/files/pkg-message.in
@@ -0,0 +1,7 @@
+===========================================================================
+Please add the following to %%PREFIX%%/%%APACHEETCDIR%%/httpd.conf:
+LoadModule auth_openidc_module %%APACHEMODDIR%%/mod_auth_openidc.so
+
+Then update the following config file with your settings:
+%%PREFIX%%/%%APACHEETCDIR%%/Includes/auth_openidc.conf
+===========================================================================
diff --git a/www/mod_auth_openidc/pkg-descr b/www/mod_auth_openidc/pkg-descr
new file mode 100644
index 000000000000..7bb88496c64d
--- /dev/null
+++ b/www/mod_auth_openidc/pkg-descr
@@ -0,0 +1,7 @@
+mod_auth_openidc is an authentication/authorization module for the Apache 2.x
+HTTP server that functions as an OpenID Connect Relying Party, authenticating
+users against an OpenID Connect Provider. It can also function as an OAuth 2.0
+Resource Server, validating OAuth 2.0 access tokens presented by OAuth 2.0
+Clients.
+
+WWW: https://github.com/pingidentity/mod_auth_openidc/
diff --git a/www/mod_auth_openidc/pkg-plist b/www/mod_auth_openidc/pkg-plist
new file mode 100644
index 000000000000..a4e7d3ff90ad
--- /dev/null
+++ b/www/mod_auth_openidc/pkg-plist
@@ -0,0 +1 @@
+@sample %%APACHEETCDIR%%/Includes/auth_openidc.conf.sample