aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_smooth_streaming/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_smooth_streaming/Makefile')
-rw-r--r--www/mod_smooth_streaming/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/mod_smooth_streaming/Makefile b/www/mod_smooth_streaming/Makefile
new file mode 100644
index 000000000000..63abb369f71b
--- /dev/null
+++ b/www/mod_smooth_streaming/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mod_smooth_streaming
+# Date created: May 25, 2010
+# Whom: Marcus Hermansson <bmhermansson@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_smooth_streaming
+PORTVERSION= 1.0.8
+CATEGORIES= www
+MASTER_SITES= http://smoothstreaming.code-shop.com/download/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+DISTNAME= apache_${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= apache22
+
+MAINTAINER=
+COMMENT= Apache smooth streaming module
+
+RESTRICTED= no-commercial-use
+
+USE_APACHE= 22+
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST+= APACHEMODDIR=${APACHEMODDIR}
+
+post-install:
+ ${LOCALBASE}/sbin/apxs -e -a -n smooth_streaming ${LOCALBASE}/${APACHEMODDIR}/${PORTNAME}.so
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>