aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 8e738a0768b2..4fb23613bb48 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -16,7 +16,8 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= osa@FreeBSD.org
COMMENT= Robust and small WWW server
-OPTIONS= DEBUG "Enable nginx debugging" off \
+OPTIONS= DEBUG "Build with debug" off \
+ DEBUGLOG "Enable debug log (--with-debug)" off \
IPV6 "Enable IPv6" off \
GOOGLE_PERFTOOLS "Enable google perftools module" off \
HTTP_MODULE "Enable HTTP module" on \
@@ -102,10 +103,13 @@ IGNORE= requires at least HTTP_MODULE or MAIL_MODULE to \
.if defined(WITH_DEBUG)
CFLAGS+= -g -DNGX_DEBUG_MALLOC
-CONFIGURE_ARGS+=--with-debug
STRIP= #do not strip if nginx with debug information
.endif
+.if defined(WITH_DEBUGLOG)
+CONFIGURE_ARGS+=--with-debug
+.endif
+
.if defined(WITH_IPV6)
CONFIGURE_ARGS+=--with-ipv6
CATEGORIES+= ipv6