aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-DBI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Apache-DBI/Makefile')
-rw-r--r--www/p5-Apache-DBI/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index ef929e5dba89..d0874bf202cd 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -15,6 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@p6m7g8.com
COMMENT= DBI persistent connection, authentication and authorization
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
@@ -34,12 +37,4 @@ BUILD_DEPENDS+= ${RUN_DEPENDS}
BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
.endif
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
.include <bsd.port.post.mk>